Find the answer to your Linux question:
Results 1 to 7 of 7
Following a thread I read on this forum I managed to find a way of getting my external hard disk to appear in the devices section of Konqueror. That isn't ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Location
    Wherever the beautiful women are.
    Posts
    99

    Success!.......Well, sort of.


    Following a thread I read on this forum I managed to find a way of getting my external hard disk to appear in the devices section of Konqueror. That isn't the problem though. Now I've done that I can remember the changes I made to the line so I could access it as a non root user. I looked through the manual again and now I'm having to go through all the combinations until I get the right one. This time though, instead of constantly typing it in the Konsole, I'm going to add a line to the fstab.

    In the Konsole I typed:

    Code:
    mount -t auto -o rw,users,umask=0033 /dev/sda1 /mnt/usb
    As I understand it, 'rw' gives read/write capabilities, /dev/sda1 is the name Linux gives it because of SCSI emulation (despite there being an IDE drive inside the enclosure). /mnt/usb is the substitute for /dev/sda1. 'users' or 'user' allows a non root user to mount the device. If I were to put owner in the the only person who could unmount the device is the one who mounted it in the first place. As for umask, I'm not sure whether it should be 0000,000 or 0033. You'll have to explain that one to me.

    It would be great if you could tell me what is wrong with that line and what to do so I can allow it to be accessed by a non-root user.

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    That line should do it. What error(s)/problem(s) are you having?
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Linux User
    Join Date
    Jul 2004
    Posts
    256
    "man 8 mount" tells you want the mask is. I believe that should end up setting the user permissions as 744. (I'm not sure about the leading zero...)

    Is the problem you cant read, or you want any user to write to it?
    --monkey

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2004
    Location
    Wherever the beautiful women are.
    Posts
    99
    Thanks for the help but I managed to fix it early this morning. The line I used to mount it via the prompt was:

    Code:
    mount -t auto -o rw,users,umask=0000 /dev/sda1 /mnt/usb
    and the line I put in the fstab reads:

    Code:
    /dev/sda1    /mnt/usb    auto    rw,users,umask=0000     0  0

  6. #5
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    The leading 0 is for the SUID bit. It's not really required in a umask arg (esp for mounting a USB drive), but it's good practice to put it there and know what it's for.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  7. #6
    Linux User
    Join Date
    Jul 2004
    Posts
    256
    Since its a mask, would that make the SUID bit 7? Is that okay?
    --monkey

  8. #7
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Actually...I was incorrect. You cannot specify SUID in a umask...this would be very unsecure. Let's just pretend that my mind was temporarily possessed by aliens earlier.

    That is the STICKY bit. With this bit set to 1, only the creator (owner) of the file can delete it (even if they have write access). With a sticky bit on a directory, you must own a file in the dir to delete it even if you have write access to the dir itself.

    Sorry about the confusion...I promise I will never be wrong again.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •