Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I seem unable to write to my floppy drive anymore, even as root. When I logged in as root and tried to access the properties of the floppy drive ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2004
    Location
    London
    Posts
    1

    Cannot write to Floppy Drive, even as root


    Hi, I seem unable to write to my floppy drive anymore, even as root. When I logged in as root and tried to access the properties of the floppy drive I got the following:-
    Owner: can view content
    group: forbidden
    others: forbidden

    When I tried to change this I got the following error message:- 'Changing the attributes of files is not supported with protocol devices'

    I used to be able to write to the floppy, so what happened? Can anyone help me?

    I have enclosed below a copy of /etc/fstab

    I am running Suse Linux 9.1 and Linux Kernal 2.6.5-7.95




    /dev/hdb7 / reiserfs acl,user_xattr 1 1
    /dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
    /dev/hdb1 /windows/D ntfs rw,users,gid=users,umask=0002,nls=utf8 0 0
    /dev/hdb2 /windows/E ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
    /dev/hda5 /windows/F ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
    /dev/hdb5 /windows/G ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
    /dev/hdb6 swap swap pri=42 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    proc /proc proc defaults 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    sysfs /sys sysfs noauto 0 0
    /dev/cdrecorder /media/cdrecorder subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=ut f8 0 0
    /dev/dvd /media/dvd subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=ut f8 0 0
    /dev/fd0 /media/floppy subfs fs=floppyfss,procuid,rw,users,nodev,nosuid,sync 0 0

  2. #2
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    did you use chmod command?login as root andt ype chmod 777 /dev/fd0..
    it may work
    Linux For Ever!

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Location
    Wherever the beautiful women are.
    Posts
    99
    That protocol devices message appears with my external hard drive when I use the copy option sometimes. To get around it I just bring the device up in Konqueror and drag the file over to it. It seems to work fine that way.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    ok, you can use it that way!
    Linux For Ever!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •