Find the answer to your Linux question:
Results 1 to 4 of 4
I have a dual boot system on my laptop Debian Sid / Windows XP. I am trying to mount NTFS partition. I have directory windows in /mnt, ls -l output: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149

    mount issue


    I have a dual boot system on my laptop Debian Sid / Windows XP.

    I am trying to mount NTFS partition.

    I have directory windows in /mnt, ls -l output:
    Code:
    ccooper-lap:/mnt# ls -l
    total 20
    drwxr-xr-x 2 root root 4096 2007-12-12 12:56 usb
    drwxrwxrwx 2 root root 4096 2007-12-13 09:45 windows
    this is before I mount the partition.
    I have it set up in /etc/fstab.
    Code:
    /dev/hda1       /mnt/windows    ntfs    defaults,errors=remount-ro 0 2
    After I type 'mount windows'.
    Code:
    ccooper-lap:/mnt# mount windows
    ccooper-lap:/mnt# ls -l
    total 28
    drwxr-xr-x 2 root root  4096 2007-12-12 12:56 usb
    drwx------ 1 root root 12288 2007-12-10 14:40 windows
    The directory goes to permission 700 rather than staying at 777. So i cannot access the files unless I am root or I do 'chmod -R 777 windows'. This makes it work but it takes a long time to do, and i don't want to have to do t his every time, anyone know what might be wrong?

    My output for mount is
    Code:
    ccooper-lap:/mnt# mount
    /dev/hda2 on / type ext3 (rw,errors=remount-ro)
    tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
    proc on /proc type proc (rw,noexec,nosuid,nodev)
    sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
    procbususb on /proc/bus/usb type usbfs (rw)
    udev on /dev type tmpfs (rw,mode=0755)
    tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
    devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
    /dev/hda4 on /home type ext3 (rw)
    /dev/hda1 on /mnt/windows type ntfs (rw,errors=remount-ro)

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    /dev/hda1 /mnt/windows ntfs defaults,errors=remount-ro 0 2
    It should be
    Code:
    /dev/hda1       /mnt/windows    ntfs    defaults,umask=0 0 0
    Install ntfs-3g to enable NTFS write access and replace ntfs with ntfs-3g in /etc/fstab file.
    Code:
    su
    apt-get install ntfs-3g
    /etc/fstab
    Code:
    /dev/hda1       /mnt/windows    ntfs-3g    defaults,umask=0 0 0
    All users will have write access in NTFS partition.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    quick today! works, thanks

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Glad to help you.
    Have fun with Linux !!!
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •