Find the answer to your Linux question:
Results 1 to 4 of 4
Hey guys. I am running Ubuntu 6.06 on a Dell Latitude D600. The problem I am having is that my computer is not detecting my ethernet card. When I run ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2007
    Posts
    1

    Ethernet Card not Working!!


    Hey guys. I am running Ubuntu 6.06 on a Dell Latitude D600. The problem I am having is that my computer is not detecting my ethernet card. When I run lspci is does not list my ethernet card and when I run ifconfig it only recognizes lo (which I assume is the dialup modem) and not eth0. I would give you a print out of these commands but I cant get on the interent with my machine . Any help will be much appreciated.

  2. #2
    Linux Newbie dilbert's Avatar
    Join Date
    Sep 2006
    Location
    Yorkshire, GB
    Posts
    237
    lo is the local loopback and doesn't need any hardware. It's an internal software port of the network stack. It's to test only the function of your internal network stack.

    ping 127.0.0.1 is running only circles in your own CPU.

    I would find out if the chip in your network card is supported by your Ubuntu version. So search for '"Dell Latitude D600" and "network card" and "chip"' or so and when you got the chip then check hardware compatibilty with Ubuntu 6.05.

    More probable is that some BIOS settings could be wrong or the network card isn't connected properly or as it is more likely on-board on the motherboard there is something wrong ith that chip.

    If you could get hold of a USB-to-Ethernet dongle you could try this one to see if you get an entry in ifconfig with "ifconfig -a".

    I'm not sure if the output of "dmesg" could yield something, maybe an error mesaage or so.
    Bus Error: Passengers dumped. Hech gap yo'q.

  3. #3
    Linux User Agent-X's Avatar
    Join Date
    May 2005
    Location
    Dimension X
    Posts
    261

    Lightbulb

    Upgrade the kernel or upgrade the distro.

  4. #4
    Just Joined! Tinky Winky's Avatar
    Join Date
    Dec 2007
    Location
    In Tellitubby land
    Posts
    21
    What Agent-X said - You probably know that Gusty is out and so is the alpha of Hardy - Ubuntu hardware compatibility has come a long way since 6.06 - get the latest kernel and upgrade to 7.10. It's what I did and about half the stuff that wouldn't work before does now. If it doesn't work, you'll at least have a more modern system.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •