Hello. I am trying to get my USB external speakers to work in PCLinuxOS. When I plug it in and go to KMix it will allow me to select both my on board sound card and my usb speakers but I cannot select the speakers for output or default to them. I have tried many other distros like Sabayo, Linux Mint, Simply Mepis, and they all seem to work wit my usb speakers. I think PCLinux only wants to output to my on board sound card. So I would like to know if i can disable my on board sound card completely? Somehow during startup? Help please!

And the reason I want to do this is because my sound card is broken. Thanks in advance.