Find the answer to your Linux question:
Results 1 to 2 of 2
I have some trouble with the Realtek RTL-8169 NIC chipset used on my mainboard: it often works, but sometimes the auto-negotiation seems to fail and it falls back to 10MBit ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2007
    Posts
    2

    Realtek RTL-8169 auto-negotiation


    I have some trouble with the Realtek RTL-8169 NIC chipset used on my mainboard: it often works, but sometimes the auto-negotiation seems to fail and it falls back to 10MBit Ethernet. After a reboot it comes up OK.

    I've tried an init.d script to force the speed to 100MBit via mii-tool, but it just happened again.. it seems the driver doesn't care much about it.

    Is there any way to get the driver to retry until 100MBit is reached or is it a bug in the r8169 module? Does anyone have similar problems?

    Linux version: 2.6.18-5-amd64 #1 SMP

  2. #2
    Just Joined!
    Join Date
    Dec 2007
    Posts
    2
    Problem possibly solved, compile r8169.ko from Realtek and install as described. Then update initrd (update-initramfs on debian) to get it to load on boot.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •