Find the answer to your Linux question:
Results 1 to 6 of 6
sorry for the length of this post.I may edit it later. In the words of Blaise Pascal "I have made this letter longer than usual, because I lack the time ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2007
    Posts
    45

    So is my harddrive okay?


    sorry for the length of this post.I may edit it later. In the words of Blaise Pascal "I have made this letter longer than usual, because I lack the time to make it short."

    I am worried my harddrive could be defective.
    Some of you may remember that I was having some issues with getting an operating system to boot-up and with getting one to install. The problem was eventually fixed, Ubuntu is now installed(as the only OS) and is running great. This is documented in the thread in my signature.
    During that whole mess, I ran a quick test diagnostic on a my harddrive(a western digital) using one of the diagnostics programs(DL Diag 5.04f) provided on the Ultimate Boot CD. The software states that the test will take approximately 6 minutes. When I ran the test my HD passed the test with no errors and the software informed me that this test took 8 minutes.
    I didn't think much more of it. And since Ubuntu was installed and working fine, I didn't feel it was necessary to bother with the extended test.

    Then I started noticing a sticking point in Ubuntu's startup process. Now, it doesn't take Ubuntu long to boot(at least not in my opinion). It still beats Vista. It usually takes anywhere from like 2-3 minutes, and that it includes the time it takes me to enter my username and password. But there is a sticking point that concerns me. When Ubuntu is at the screen with the loading bar, it will fill up to about a half-centimeter and stick there for a few seconds( I don't know how long exactly, I haven't timed it. I need to use a timepiece that can display seconds). But after that, the majority of the bar seems to load smoothly and the Ubuntu is soon up and running.

    I thought to myself that maybe I should run the more thorough harddrive diagnostic, the extended test. So I load up the Ultimate Boot CD again, go to the HD extended diagnostic, and it says it has to run the quick test first. I agree, and I go eat and watch some tv. I come back to my computer to find that the diagnostic never got to the extended test. As a matter of fact, it never even finished the quick test! It said "Test aborted. It ran too far beyond the expected time. Error code: 0210". I don't know how long it took, because I wasn't keeping time. But I powered off the system and didn't power it back up until today. I ran the test again first thing, but this time I was watching the clock. To make a long story short, the quick test did not complete this time either. The bar made good progress for about the first 6 minutes and then basically stopped cold in its tracks about a centimeter from the finish point. After 12 minutes(twice the time estimated by the diagnostic software for the test to complete), the software aborted the test and gave me the same message and error code listed above.

    Do you think there is something wrong with my harddrive? The load time for Ubuntu(2-3 minutes) isn't that bad, but I hope it isn't going to turn into something worse. I think my prior issue was mainly a software/partition issue, but I suspect that my harddrive's slowness may have had something to do with it. But the problem is gone now, so I am pretty sure that my software/partition issue was the main cause of the problem. Everything is running fine, so maybe I am worried about nothing. But that diagnostic should have completed and now I am concerned.

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    I have no idea, but according to WD's Diagnotic Error Codes page, it appears that you have a failed drive if you have repeated the test and get the same error code again.
    oz

  3. #3
    Just Joined!
    Join Date
    Dec 2007
    Posts
    45
    Thanks for looking that up ozar. This really sucks a big one. I thought maybe it was something I could live with for a while, but it is starting a pattern of deterioration. Today it took a very long time to boot. Maybe like six or seven minutes. So I have doubts whether or not this thing is going to boot again at all. Thankfully, this computer is still well within warranty so this will get taken care of. The partition thing, *may* have been an issue, but it appears now that it was not the main one. My "fix" appeared to just simply buy me some more time. lol, well so much for this sig. I'm going to get rid of it. I learned a lot though. But anyway, I'm going to contact tech support and get the ball rolling on getting this drive replaced.
    Thanks again for your help. I will definitely be back on linuxforums when this problem is resolved.

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Ubuntu boots up in 30-40 seconds in my machine. I dont know much about Hardware issues and can't help you there but lets check what processes Ubuntu runs during boot up. Execute this
    Code:
    cat /etc/lsb-release
    ls /etc/rc2.d
    Post output here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Dec 2007
    Posts
    45
    Hey DC. Here is the first output:

    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=7.10
    DISTRIB_CODENAME=gutsy
    DISTRIB_DESCRIPTION="Ubuntu 7.10"
    The second
    README S20firestarter S89anacron
    S05vbesave S20hotkey-setup S89atd
    S10acpid S20makedev S89cron
    S10powernowd.early S20nvidia-kernel S98usplash
    S10sysklogd S20powernowd S99acpi-support
    S10xserver-xorg-input-wacom S20rsync S99laptop-mode
    S11klogd S22consolekit S99rc.local
    S12dbus S24avahi-daemon S99rmnologin
    S12hal S24dhcdbd S99stop-readahead
    S19cupsys S25bluetooth
    S20apport S30gdm
    Thanks

  6. #6
    Just Joined!
    Join Date
    Nov 2007
    Posts
    12

    Lightbulb

    Please be specific. What I could make out from your description is that either your diagnostic tool might have gone corrupt so go for some other diagnostic tool and than check whether your harddrive is Ok or not.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •