Find the answer to your Linux question:
Results 1 to 4 of 4
Hi All, I'm in the process of building a PVR/HTTPC and have got stuck trying to get the sound to work. Specifications: Abit motherboard (NF-M2SV), with following sound chip: 00:05.0 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    4

    Problem getting sound to work


    Hi All,
    I'm in the process of building a PVR/HTTPC and have got stuck trying to get the sound to work.

    Specifications:
    Abit motherboard (NF-M2SV), with following sound chip:
    00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2) (according to lspci)
    SuSe Linux 10.3 with KDE desktop
    kernel version: 2.6.22.13-0.3
    sound module installed: snd-hda-intel

    aplay -l gives:
    card 0: NVidia [HDA NVidia], device 0: ALC662 Analog [ALC662 Analog]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    (KMix reports Realtek ALC662 rev 1.)


    Everything seems to install/work OK, but I've not been able to get any sound out!
    (I have adjusted the mixer settings using KMix). I've tried a number of users (inc. root) (and all users are member of 'audio') to no avail.lsamixer: function snd_mixer_load failed: Invalid argument

    Running alsamixer gives:
    alsamixer: function snd_mixer_load failed: Invalid argument
    which I can see other people struggle with as well, but I haven't seen any solutions for this specific problem anywhere.


    I've tried re-installing the sound card with alsaconf, which seems to work perfectly, but again there's no sound at the end of it.



    Any solutions or tips for diagnosis of the problem would be very much appreciated!

    Wessel

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined!
    Join Date
    Aug 2006
    Posts
    4
    Thanks for the tip. I've tried it, but it makes no difference, still can't get any sound out.

    Thanks anyway.

    Wessel

  4. #4
    Just Joined!
    Join Date
    Aug 2006
    Posts
    4
    I've managed to get it to work (in case anybody else has this problem) by doing the following:

    -uninstall all alsa-related packages usign yast (ignore dependency conflicts that will arise)
    -compile latest version of alsa drivers, library and utils. (download from alsa project website) (follow instructions in INSTALL files to do this)
    -after running 'snddevices', alsamixer suddenly worked and I had sound! (after upping the channel volumes)
    -I stored the mixer settings using 'alsactl store'

    (To be honest, I'm not sure if all the removal and installation of latest version was strictly necessary. Mabye the trick was running 'snddevices', so you might want to try that first)

    The only problem is that I have to rerun the snddevices script after every boot. I suspect that there's some new-hardware discover thingy at boot that 'knows better' and changes stuff in /dev/snd, which I then have to undo again using 'snddevices'. Not yet sure how to solve this. (I've seen other posts on the web related to this problem, but haven't seen a real solution, other than automating re-running snddevices after every boot cycle). Suggestions welcome!

    Wessel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •