Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I"m having problems mounting my cdrom drive... i've done everything I can think of and still no luck so i'm hopin someone can help me out. if i try ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    37

    Can't mount cdrom


    Hi, I"m having problems mounting my cdrom drive... i've done everything I can think of and still no luck so i'm hopin someone can help me out.

    if i try to mount my cdrom as root of course i get this:

    mount /mnt/cdrom
    mount /dev/cdrom /mnt/cdrom
    mount /dev/hdd /mnt/cdrom

    no matter what i get:

    /dev/cdrom is not a valid block device.
    dev/hdd is not a valid block device.

    But if i check out /proc/ide/hdd everything shows up as my cdrom drive.

    I do ls -al /dev/cdrom:

    /dev/cdrom --> /dev/hdd

    I have /dev/cdrom in my fstab:

    /dev/cdrom /mnt/cdrom iso9660 noauto,noowner,ro 0 0

    something like that.. it's all there, so my mount point is defined.

    I have no idea what is wrong... I have however ran ./MAKEDEV as root :S thinking that would fix my alsa devices before... i'm not sure if that would have messed anything up, please any help is appreciated.

  2. #2
    Just Joined!
    Join Date
    Jul 2004
    Location
    Wherever the beautiful women are.
    Posts
    99
    /dev/cdrom /mnt/cdrom iso9660 noauto,noowner,ro 0 0

    As far as I know there is no such thing as noowner. If there was, it doesn't sound like it would do any good.

    Try changing this:

    noauto,noowner,ro

    to this:

    noauto,users,ro

    When you right click on the device icon and select properties in root, make sure that the user is a non-root account and you have all the appropriate advanced access permissions.

  3. #3
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    u do have a cd in the drive right? u get that error if u try to mount an empty drive.

    noowner was probably made by ur install program so that u dont have to worry about setting up the drive for non-root users

    if u have a custom kernel check that u have enabled iso9660 support.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •