Find the answer to your Linux question:
Results 1 to 3 of 3
I have an RHEL4 system with an LSI MegaRaid SCSI Card. After a reboot yesterday, the megaraid utils megamgr and megarc no longer work. Code: ./megarc -AllAdpInfo -nolog ********************************************************************** MEGARC ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie humbletech99's Avatar
    Join Date
    Nov 2005
    Posts
    225

    LSI MegaRaid utilities no longer work


    I have an RHEL4 system with an LSI MegaRaid SCSI Card. After a reboot yesterday, the megaraid utils megamgr and megarc no longer work.
    Code:
    ./megarc -AllAdpInfo -nolog
    
            **********************************************************************
                  MEGARC MegaRAID Configuration Utility(LINUX)-1.11(12-07-2004)     
                  By LSI Logic Corp.,USA
            **********************************************************************
              [Note: For SATA-2, 4 and 6 channel controllers, please specify
              Ch=0 Id=0..15 for specifying physical drive(Ch=channel, Id=Target)]
    
            Type ? as command line arg for help
    and when running megamgr to get the ncurses utility it says
    Code:
    Failed to Know Fw type
    Press Any key to Continue.
    followed by
    Code:
    Error Performing Adapter Enquiry.
    Press any key to continue..
    Code:
    No Adapters Found.
    Press any key to exit.
    The disks are still accessible, the driver modules are loaded otherwise the disks wouldn't be accessible.

    /proc/devices shows the megadev device and I have the /dev/megadev0 device as well.

    This all worked until the machine reboot yesterday and I haven't changed anything. I've even redownloaded megamgr and I get the same result.

    I'm out of ideas, anyone?
    The Human Equation:

    value(geeks) > value(mundanes)

  2. #2
    Just Joined!
    Join Date
    Feb 2008
    Posts
    4
    I know this doesn't help you much but I've had problems with LSI drives for a while.

    Better luck the Areca or 3ware actually.

    Sorry I don't have a solution for you but at least for those that haven't bought yet...

    ltg

  3. #3
    Linux Newbie humbletech99's Avatar
    Join Date
    Nov 2005
    Posts
    225
    I've got lots of Lsi and generally they're quite good, it's only this one that has suddenly stopped working properly in communicating with the raid utilities...
    The Human Equation:

    value(geeks) > value(mundanes)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •