Find the answer to your Linux question:
Results 1 to 1 of 1
My system: MyBook Western Digital external 1 TB drive, mounted via firewire. Debian "stable" (mostly). Linux 2.6.15, compiled locally My problem: Mount says "mounting fs with errors, running e2fsck is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2008
    Location
    Florida, USA
    Posts
    1

    e2fsck reports no problems, but mount warns of errors


    My system:

    MyBook Western Digital external 1 TB drive, mounted via firewire.
    Debian "stable" (mostly).
    Linux 2.6.15, compiled locally

    My problem:

    Mount says "mounting fs with errors, running e2fsck is recommended"
    Ran e2fsck (twice; took an hour each time), no errors reported
    Mount still says "mounting fs with errors, running e2fsck is recommended"
    dumpe2fs says "Filesystem state: clean with errors"

    My question:

    How to clear the "error" bit? Leery of using drive that doesn't mount cleanly.

    Thanks for any help!

    Update: Problem solved.

    The first two fsck's I ran, which didn't solve the problem, but nevertheless appeared to run a thorough check, were:
    fsck.ext3 /dev/sdb2
    e2fsck -C 0 -p -tt /dev/sdb2

    The third fsck cleared the error bit, I think because of the "-f" flag:
    e2fsck -F -f -C 0 -v /dev/sdb2

    Thanks anyway!
    Last edited by theclapp; 03-28-2008 at 01:28 AM. Reason: answered my own question

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •