Find the answer to your Linux question:
Results 1 to 3 of 3
Hello! I'm really really new to linux, in fact just two weeks, and I think I messed up with some configuration. I had a resolution of 1024 x 7** and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    8

    Cannot start the X server, help!!


    Hello! I'm really really new to linux, in fact just two weeks, and I think I messed up with some configuration. I had a resolution of 1024 x 7** and something happened and it changed to 800 x 600. So I tried to get it back to the original state using the utility in KDE, but I don't know what happened and now I'm getting this when I restart the computer:

    Code:
    "I cannot start the x server it is likely that it is not setup correctly would you like to view the x server output to diagnose the problem"
    then I choose yes and it says

    Code:
    "Parse error on line 1 of section (null) in file /etc/x11/XF86Config 
      "script.so.0" is not a value keyword in this section. 
    Problem Parsing the config file 
    Error form xf86HandleConfig File 
     Would you like me to run the x server configuration program"


    then I choose yes, and it takes me to a graphical configuration program where I can choose the monitor setting, and video card settings and other configurations.

    then it gets me out of the program but i get the same error over and over again, and I can't do anything else, not even ls command works.
    I tried several configurations but nothing has worked.


    I'm using an ecs laptop which has a 14.1? XGA TFT-LCD screen with 1024 x 768 resolution. And has a SiS 630ST chipset (I do not know what it is for but those the only things I've found concerning the monitor).
    I'm using Slackware 9.

    Do you think there's a solution?? or do I have to reinstall everything again???
    I could really really use some help!!! Any comments are welcome. Thanks

  2. #2
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284
    open up /etc/x11/XF86Config in a text editor. Do you have "script.so.0" on line 1? if so remove the line.

    If not, check /etc/xorg.conf or /etc/x11/XF86Config-4 for the same thing. (these files may be empty/not exist if thats the case just move onto the next one).

    Jason

  3. #3
    Just Joined!
    Join Date
    Aug 2004
    Posts
    8

    mmm... text editor???

    mmm the thing is that when I get out of the configuration program, I get into a prompt black screen, with some instructions or comments of programs that have been loaded, but if I type anything and hit enter then just nothing happens. I've tried typing ls but nothing happens.

    What is the command to access a text editor, what should I try typping?

    Once I tried hitting F5 and F1 to see if I could start with another runlevel but it just doesn't work. Any ideas?

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •