I have a problem with my USB connections. For some resons they are not quite doing what they should. I have a new camera and on my old laptop (running Ubuntu 8.04) it is detected immediately on the old USB 1.0. On my brand new PC also running Ubuntu 8.04 it is not detected. all my other USB devices are running fine apart from the inbuilt USB card reader in my HP PSC1300. For my Camera dmesg is showing the following:

[ 563.332000] end_request: I/O error, dev sdb, sector 60796
[ 563.332000] printk: 24 messages suppressed.
[ 563.332000] Buffer I/O error on device sdb1, logical block 60745
[ 717.556000] usb 2-4: new high speed USB device using ehci_hcd and address 12
[ 717.668000] usb 2-4: device descriptor read/64, error -71
[ 717.884000] usb 2-4: device descriptor read/64, error -71
[ 718.100000] usb 2-4: new high speed USB device using ehci_hcd and address 13
[ 718.212000] usb 2-4: device descriptor read/64, error -71
[ 718.428000] usb 2-4: device descriptor read/64, error -71
[ 718.644000] usb 2-4: new high speed USB device using ehci_hcd and address 14
[ 719.052000] usb 2-4: device not accepting address 14, error -71
[ 719.164000] usb 2-4: new high speed USB device using ehci_hcd and address 15
[ 719.572000] usb 2-4: device not accepting address 15, error -71
[ 801.752000] usb 2-4: new high speed USB device using ehci_hcd and address 16
[ 801.864000] usb 2-4: device descriptor read/64, error -71
[ 802.080000] usb 2-4: device descriptor read/64, error -71
[ 802.296000] usb 2-4: new high speed USB device using ehci_hcd and address 17
[ 802.408000] usb 2-4: device descriptor read/64, error -71
[ 802.624000] usb 2-4: device descriptor read/64, error -71
[ 802.840000] usb 2-4: new high speed USB device using ehci_hcd and address 18
[ 803.248000] usb 2-4: device not accepting address 18, error -71
[ 803.360000] usb 2-4: new high speed USB device using ehci_hcd and address 19
[ 803.768000] usb 2-4: device not accepting address 19, error -71
then found this solution but don't know how to do the diabling:

Re: Error -71 on device descriptor read/all
Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
From: Chuck Ebbert <cebbert@...>
To: Renato S. Yamane <renatoyamane@...>
Cc: <linux-kernel@...>, USB development list <linux-usb-devel@...>
Subject: Re: Error -71 on device descriptor read/all
Date: Tuesday, June 19, 2007 - 12:17 pm

On 06/19/2007 10:45 AM, Renato S. Yamane wrote:
quoted text
> Hi, > I see this in dmesg: > usb 1-1: device descriptor read/all, error -71 > > Using 2.6.21.1 > > Someone know what it is? >

Try disabling CONFIG_USB_SUSPEND
link to that forum with the above solution is:
mailing list archives | KernelTrap

Anyone can help with helping me to disable the CONFIG_USB_SUSPEND?

Thanks