Find the answer to your Linux question:
Results 1 to 5 of 5
Hi, I just installed Mandrake 9.1 on a system because there are some legacy products that use the 2.4 kernel that I have to support. Anyway, I tried to use ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Apr 2008
    Posts
    128

    USB problem on Mandrake 9.1


    Hi,

    I just installed Mandrake 9.1 on a system because there are some legacy products that use the 2.4 kernel that I have to support.

    Anyway, I tried to use a USB flash drive and noticed that it couldn't be found in /dev, so I did a lsusb and got the following:
    Code:
    Invalid product/subclass spec at line 2650
    cannot open /proc/bus/usb, No such file or directory (2)
    Sure enough, I go to /proc/bus/ and only find pci/ in there, nothing else.

    I also did an lsmod and got the following:
    Code:
    Module                  Size  Used by    Not tainted
    nfsd                   74256   0  (autoclean)
    af_packet              14952   1  (autoclean)
    floppy                 55132   0 
    3c59x                  29584   1  (autoclean)
    supermount             15296   2  (autoclean)
    rtc                     8060   0  (autoclean)
    ext3                   59916   1 
    jbd                    38972   1  [ext3]
    lspci returned the following:

    Code:
    00:00.0 Host bridge: Intel Corp.: Unknown device 2580 (rev 04)
    00:02.0 VGA compatible controller: Intel Corp.: Unknown device 2582 (rev 04)
    00:1c.0 PCI bridge: Intel Corp.: Unknown device 2660 (rev 04)
    00:1d.0 USB Controller: Intel Corp.: Unknown device 2658 (rev 04)
    00:1d.1 USB Controller: Intel Corp.: Unknown device 2659 (rev 04)
    00:1d.2 USB Controller: Intel Corp.: Unknown device 265a (rev 04)
    00:1d.7 USB Controller: Intel Corp.: Unknown device 265c (rev 04)
    00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB PCI Bridge (rev d4)
    00:1e.2 Multimedia audio controller: Intel Corp.: Unknown device 266e (rev 04)
    00:1f.0 ISA bridge: Intel Corp.: Unknown device 2640 (rev 04)
    00:1f.1 IDE interface: Intel Corp.: Unknown device 266f (rev 04)
    00:1f.3 SMBus: Intel Corp.: Unknown device 266a (rev 04)
    02:00.0 Ethernet controller: Broadcom Corporation: Unknown device 167e (rev 11)
    0a:01.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev 30)
    "dmesg | grep usb" returned nothing.

    Strangely, my USB mouse is working.

    Does anyone know what's wrong? I'm a linux noob so I don't have much of an idea what's going on.

    TIA.

  2. #2
    Linux Newbie
    Join Date
    Apr 2008
    Posts
    128
    OK I did a "modprobe uhci" before mounting usbdevfs and now lsusb shows the connected USB devices and I'm able to mount my flash drive. However, once I do the modprobe, my USB mouse stops working. Any help?

  3. #3
    Just Joined!
    Join Date
    Jun 2008
    Location
    Chittagong, Bangladesh
    Posts
    1

    Cool USe New version


    Hi TIA,
    i think it is not a good idea to use mandrake version of Linux on PC.
    u must use latest version of Linux mandrake called Linux Mandriva 2008.

    it is very nice to use...i have already use it & it works better than mandrake.
    u can also try any other latest Linux distribution such as- Fedora, slax, ubuntu etc.
    they are all nice & i think your USB problem will be solved by using latest Linux distribution.

    Hoping u will enjoy new look in Linux......

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Apr 2008
    Posts
    128
    Hi,

    Like I said I'm forced to use Mandrake 9.1 because the original product was developed on this platform, on a 2.4 kernel. I have a separate HDD with Mandriva 2008 too, but I HAVE to get the Mandrake 9.1 to work on my system as well. Any ideas?

    btw TIA isn't my name, TIA means "thanks in advance"

  6. #5
    Linux Newbie
    Join Date
    Apr 2008
    Posts
    128
    Anyone?

    I tried mounting usbdevfs but it keeps telling me that /proc/bus/usb doesn't exist.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •