Find the answer to your Linux question:
Results 1 to 8 of 8
I'm trying to install an EPSON Stylus Color 600 printer, but the parallel port (/dev/lp0) doens't seem to be recognized. I've tried using "Add Printer Wizard", but when I get ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    1

    /dev/lp0 not recognized


    I'm trying to install an EPSON Stylus Color 600 printer, but the parallel port (/dev/lp0) doens't seem to be recognized. I've tried using "Add Printer Wizard", but when I get to "Local Port Selection", there's nothing under "Parallel". The commands "modprobe parport lp" and "/etc/init.d/cupsys restart" didn't seem to help. Also, the command "text.txt > /dev/lp0" returns the message "bash: /dev/lp0: No such device or address". Any thoughts on what may be happening? Just to let you know, I may be making a very stupid mistake, since I'm new at Linux.

    Thanks for the help,
    Tiago

  2. #2
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    sounds to me like you dont have parralell support compiled into your kernel. It may (hopefully) be an available module, what distro do you use and what kernel version (uname -a for kernel version) please also post the output of "lsmod". Do you have the kernel source installed?

  3. #3
    Just Joined!
    Join Date
    Aug 2004
    Posts
    2

    Any luck? (I"m on a thinkpad 770 and still no luck)

    I'm on a thinkpad 770 with Fedora Core 2 and the parallel port simply isn't recognized as 'being there' even though it is.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    yes thats what would happen if your kernel did not have parralel support. please post the rest of the information i requested.

  6. #5
    Just Joined!
    Join Date
    Aug 2004
    Posts
    2

    specs...

    Thinkpad 770
    Fedora Core 2
    2.6.7-1.494.2.2

    [root@localhost root]# lsmod
    Module Size Used by
    aes 31361 1
    yenta_socket 15809 1
    superio 8840 0
    thinkpad 6660 1 superio
    snd_mixer_oss 14785 0
    snd 46885 1 snd_mixer_oss
    soundcore 7713 1 snd
    parport_pc 21248 0
    lp 9773 0
    parport 36361 2 parport_pc,lp
    autofs4 20933 0
    sunrpc 142373 1
    airo_cs 5317 1
    ds 12997 5 airo_cs
    airo 59481 1 airo_cs
    pcmcia_core 50953 3 yenta_socket,airo_cs,ds
    floppy 54513 0
    sg 29153 0
    dm_mod 47573 0
    sd_mod 17601 0
    usb_storage 57865 0
    scsi_mod 106001 3 sg,sd_mod,usb_storage
    usblp 11329 0
    uhci_hcd 28633 0
    ipv6 218117 8
    ext3 96681 2
    jbd 66393 1 ext3

    Yep, parport appears to be in there....

  7. #6
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    In your BIOS, turn off plug-and-play support.

    Quote Originally Posted by The Printing HOWTO
    The BIOS

    Many PC BIOSes will make the parallel port into a Plug-and-Play device. This just adds needless complexity to a perfectly simple device that is nearly always present; turn off the PnP setting for your parallel port ("LPT1" in many BIOSes) if your parallel port isn't detected by the Linux driver. The correct setting is often called "legacy", "ISA", or "0x378", but probably not "disabled".
    http://www.linuxforums.org/tutorials...parport-device
    /IMHO
    //got nothin'
    ///this use to look better

  8. #7
    Just Joined!
    Join Date
    Aug 2006
    Posts
    2

    Creating /dev/lp0

    I found this by searching through threads.

    I have a Mandriva 10.1 installation that did not have /dev/lp0 when I attached a printer. I did a Google search, found a recommendation to modprobe lp, which did work, after which I was able to install a printer. I then rebooted, after which /dev/lp0 was again not present. I repeated modprobe lp and then did depmod -a, and the printer was again functional, but not present after next reboot. I do not have PnP enabled in system BIOS and have tried adding a line "lp" to /etc/modules, which also did not help. What am I missing? I do need to have the printer available on boot without having to execute modprobe lp every time.

  9. #8
    Just Joined!
    Join Date
    Aug 2006
    Posts
    2

    /dev/lp0

    This is a response to my own post. It appears that it was a mistake to post my question as a reply to an existing thread, since I haven't gotten any answers. However, I have solved my own problem and wish to share for the benefit of anybody who has had a similar problem. The program /etc/rc.d/rc.modules is supposed to look in /etc/modprobe.preload OR /etc/modules for names of modules to load at boot, but this seems to be broken on my copy of Mandriva 10.1. However, my problem of nonpersistence of modprobe lp through the next boot seems to be solved by simply adding the line

    modprobe lp

    at the end of /etc/rc.d/rc.modules. This may be the bubble gum and chicken wire method, but it works on my installation.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •