Find the answer to your Linux question:
Results 1 to 6 of 6
I use my pen drive a lot to hold, and transfer files. One day while I was pulling it out of my laptop, it slipped, and fell on a tile ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! TuxXin's Avatar
    Join Date
    Apr 2008
    Posts
    23

    Exclamation Usb pen drive broken?


    I use my pen drive a lot to hold, and transfer files. One day while I was pulling it out of my laptop, it slipped, and fell on a tile floor. I popped it back in to see if it was alright, but it didn't show up. I checked /dev, and sdc seems to be my pen drive. I tried formating it, but I get an error saying no medium is found. Is it dead, or is there something I'm missing?

  2. #2
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,040
    What does fdisk -l report? Have you tried to manually mount the drive?

  3. #3
    Just Joined! TuxXin's Avatar
    Join Date
    Apr 2008
    Posts
    23
    Code:
     fdisk -l
    
    Disk /dev/sda: 2000 MB, 2000388096 bytes
    255 heads, 63 sectors/track, 243 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x000b99e2
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1   *           1           4       32098+  83  Linux
    /dev/sda2               5         243     1919767+  83  Linux
    There is nothing to mount on sdc. There are no partitions.

  4. #4
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,040
    If you only have sda listed when you have the USB drive connected that sounds like the pen drive is not working. Do you get no listing at all for the pen drive or just no partitions listed?

  5. #5
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Check the warranty period on the drive. Corsair recently replaced my flash drive free of charge when it stopped working and they didn't even ask for any proof of purchase.

    Otherwise, I'm seeing 4GB flash drives being sold for under $15 now.
    oz

  6. #6
    Just Joined! TuxXin's Avatar
    Join Date
    Apr 2008
    Posts
    23
    When I plug my pen dri ve in, sdc appears. Otherwise, it is like it doesn't exist.

    It isn't 90 days old, so I should be able to return it. I just wanted to know if it could be fixed now, because it is going to take a while before I get one back in return. Well, thanks anyway.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •