Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, I'd really appreciate some help here, I am at the end of my rope after trying for almost 2 weeks to get a new computer working with Linux. The ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2008
    Posts
    2

    Cannot get new computer to work...


    Hello,

    I'd really appreciate some help here, I am at the end of my rope after trying for almost 2 weeks to get a new computer working with Linux. The problem is that the machine runs Windows flawlessly, so I can't return it to the store, as apparently the hardware itself is fine.

    What happens is that eventually 'random' errors start to crop up. The install might go ok, but when I download updates, I get errors complaining that several of the packages are corrupt and can't be installed. Also when I download large files from the internet, sometimes they arrive corrupt (incorrect MD5sum). I thought that there might be a networking problem, but it isn't just that: I also get faulty results in compiling (locally). For example, I might compile a project and and have it crash when I run it (in exactly the same way each time - as if the generated binaries are faulty), but then I do clean, compile it again, and it runs fine.

    This basically makes it impossible to use the machine for anything serious (which I need - this is intended to be a development machine).

    The machine is the following:

    Core 2 Duo E8400
    Gigabyte GA-EP35-DS3L motherboard
    4GB RAM (OCZ)
    Gigabyte NVidia 9600 GT video card
    Western Digital 250GB hard drive

    I have tried both Ubuntu (Hardy) and Fedora (9), same issues on both, so I don't think it's distro-specific. I tried 32-bit installations for simplicity, but also once I tried 64-bit. I've installed from scratch at least 6 times now, and the same sort of issues occur. The CDs I am installing from have been verified and they are fine.

    All hardware tests I have tried turn out ok: I did cpuburn for a long time, memtest, prime95, I tried scanning for bad sectors repeatedly (e2fsck -c -c) and found none. It's the strangest thing.

    Note that this is without the binary NVidia drivers, so that isn't the issue (however, when I install them, the card runs 3D fine).

    Any ideas on how to figure this out are much appreciated!

  2. #2
    Just Joined!
    Join Date
    Jul 2008
    Posts
    2
    Ok, I have some progress with my situation here, but I'm still baffled.

    I have found a problem that seems to be reproducible: I compile a project dozens of times, generating a 6MB binary, and then I md5sum all the results to see if they are all the same. When I run this test in a ramdrive - /dev/shm - I get perfect results, as I would expect. However, when I run it on the hard drive - the same sources, same compiler, same everything, just on the hard drive - then I get around 10-20% of the binaries with some random md5sum, I guess that means there is at least one byte that is incorrect in those. Likewise, when I do this process on a USB flash drive, I get about the same.

    This seems to indicate that CPU and RAM are ok - since ramdrive compilation succeeds, which makes sense since memtest, memtest+ and cpuburn find nothing wrong. What I am less sure is what it indicates is the problem, since I get errors on both hard drive and USB.

    I guess the question is, what is shared between the hard drive and the USB drive, but not RAM, that might be the faulty component here. Also still unclear is why I encounter no errors running Windows on the same machine.

    Any ideas?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •