Find the answer to your Linux question:
Results 1 to 3 of 3
Being new to udev, I read tutorials, howtos, and everything else I could find to create the following rule: SUBSYSTEM=="pci", ATTR{class}=="0xff0000", ATTR{device}=="0x0363", ATTR{vendor}=="0x193f", NAME="myboard" The problem I am having, is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2007
    Posts
    4

    udev ignoring my rules


    Being new to udev, I read tutorials, howtos, and everything else I could find to create the following rule:

    SUBSYSTEM=="pci", ATTR{class}=="0xff0000", ATTR{device}=="0x0363", ATTR{vendor}=="0x193f", NAME="myboard"

    The problem I am having, is that the device node does not show up as "myboard" (I don't know if it even shows up in /dev/ at all, since I don't know what the kernel would name a device of class 0xff0000 by default).

    I got the matching rules via udevinfo -ap /sys/bus/pci/devices/<device_number>.

    I have tried placing the rule in 10-local.rules and 98-local.rules at different times, to no effect.

    When reviewing the kernel log, I find the following messages:

    "udev_rules_get_run: rule applied, 'aha_363_board' is ignored"
    and
    "udev_device_event: device event will be ignored"


    It appears to me that udev is ignoring the rule that requests naming the device node "myboard". Can anyone tell me:

    1) If this deduction is correct, and if so, why?
    2) If my rule contains an error that might prevent creation or renaming of the /dev node?
    3) What I might do to have my node appear as "myboard", or where I might look for more information?

    As previously stated, I am new to udev, so any direction would be helpful. I've tried all of the resources I could find on Google without luck.

    Thanks in advance.

  2. #2
    Just Joined!
    Join Date
    Jul 2008
    Posts
    3
    Hi
    You can try using SYMLINK+="myboard" instead of using NAME=

    Also try using less ATTR{ }'s untill you can get it to work, that way there is less chance that the rule is being ignored.

  3. #3
    Just Joined!
    Join Date
    Aug 2007
    Posts
    4
    Thanks for the reply sdk32285. I tried that, and it did not work for me either.

    I did find some more information though. According to the RELEASE-NOTES file in the udev source code directory, your node is not created by using the NAME rule:

    "udev 074
    ========
    NAME="" will not create any nodes, but execute RUN keys. To completely
    ignore an event the OPTION "ignore_device" should be used."

    I still don't know why a SYMLINK wasn't created when I tried it, but developing a script for the RUN key gives me something else to try for now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •