Find the answer to your Linux question:
Results 1 to 2 of 2
I just gave my computer a spiffy hardware upgrade, and now I can't get any operating systems to work on it. Specs: Motherboard: Intel Classic Series DG33BU (also identified as ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2007
    Location
    Fairbanks, Alaska
    Posts
    25

    Unhappy No ethernet (or CD/DVD) after hardware upgrade (prob. w/ Intel DG33BU motherboard?)


    I just gave my computer a spiffy hardware upgrade, and now I can't get any operating systems to work on it.

    Specs:
    • Motherboard: Intel Classic Series DG33BU (also identified as Intel LGA775 DG33BUC)
    • Storage controller: Promise Ultra 133 TX2
    • Processor: Intel Core 2 Quad Q6600
    • Graphics card: Sapphire, ATI Radeon X1650 PRO 512MB
    • Optical drive (not upgraded): LG GCC-4480B CD-RW/DVD-ROM
    I tried all the live/installation discs at my house, with these results:
    • MEPIS 7.0, which installed perfectly, does not connect to the Internet. There seems to be no /eth0 device.
    • Debian 4.0 cannot detect the CD/DVD drive.
    • Kubuntu 8.04 install will not (1) Auto-configure network with DHCP, (2) Select and install software, (3) Build LTSP chroot, or (4) Install the GRUB boot loader on a hard disk.
    • Fedora 7 (live CD) will not connect to the Internet.
    • Slackware 12.0 can't find a CD/DVD drive.
    • openSUSE 10.2 reports, "An error occurred during the installation." I looked for I/O ports and for devices -- no eth0 is mentioned.
    • Gentoo "Could not find CD to boot, something else needed!"
    If I had to guess, I'd say that Linux doesn't play well with the motherboard -- and some distros less well than others. One post in Linux Forums suggests that the DG33BU (or DG33BUC) may not be supported. It referenced Intel's Desktop Boards page, which seems to confirm that.

    If the mobo isn't supported, or has limited support, what are my options? Are there drivers to download? Do I need a newer kernel? Do I need to scrap my mobo in favor of one with known Linux support? If I must scrap, is there a clearinghouse for information on Linux-compatible (or particular-distro-compatible) motherboards?

    I'd like to continue using SimplyMEPIS, or another Debian-derivative -- but, really, anything will do for the moment. Is anybody else using the Intel DG33BU successfully?

  2. #2
    Just Joined!
    Join Date
    Jul 2007
    Location
    Fairbanks, Alaska
    Posts
    25

    Thumbs up Solved!

    Problem solved:

    I learned from Intel's product page for the DG33BU that it uses the 82566DC Gigabit Ethernet Controller. I found suggestions elsewhere that the e1000 driver was needed. A little Googling found me the MEPIS page on the 82566 chipset; it seems to offer a solution less radical than rebuilding my kernel.

    So far, it seems to work. See post here for fuller explanation.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •