Find the answer to your Linux question:
Results 1 to 10 of 10
Hello, I am trying to get my Brother printer to work but have run out of ideas. It's the mfc 420cn. I did find the Linux mfc420cnlpr drivers and installed ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2008
    Location
    Detroit area
    Posts
    13

    [SOLVED] Brother MFC 420CN USB printer


    Hello,
    I am trying to get my Brother printer to work but have run out of ideas. It's the mfc 420cn. I did find the Linux mfc420cnlpr drivers and installed them. It now shows up the the printer setup and prints a test page perfectly, however, I cannot get it to print from any document or web page. It shows in the kde control module as being "idle (accepting jobs), but it just won't print for me. It even showed up in the queue once, but never printed. This printer works fine in XP pro. Please help me out here if you can.
    Thank You,
    jaybee

  2. #2
    Just Joined!
    Join Date
    Dec 2007
    Posts
    86
    Register your printer at:

    http://localhost:631/admin/

    and go from the error message at:

    http://localhost:631/admin/printers.


    There are loads of handy tools on that web page, to check and control your printer.

    It is the CUPS-Administration page from the CUPS-webs site.

  3. #3
    Just Joined!
    Join Date
    Aug 2008
    Location
    Detroit area
    Posts
    13
    Awesome. Thanks for the scoop. I'll try that now.
    jaybee

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2008
    Location
    Detroit area
    Posts
    13

    some of the errors from report

    I [15/Aug/2008:00:00:02 -0400] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=31264)
    I [15/Aug/2008:00:00:02 -0400] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=31265)
    I [15/Aug/2008:00:01:00 -0400] Scheduler shutting down normally.
    I [15/Aug/2008:00:01:00 -0400] Saving remote.cache...
    I [15/Aug/2008:00:01:00 -0400] Saving job cache file "/var/cache/cups/job.cache"...
    I [15/Aug/2008:00:15:45 -0400] Loaded configuration file "/etc/cups/cupsd.conf"
    N [15/Aug/2008:00:15:45 -0400] Group and SystemGroup cannot use the same groups!
    I [15/Aug/2008:00:15:45 -0400] Resetting Group to "root"...
    I [15/Aug/2008:00:15:45 -0400] Cleaning out old temporary files in "/var/spool/cups/tmp"...
    I [15/Aug/2008:00:15:45 -0400] Configured for up to 100 clients.
    I [15/Aug/2008:00:15:45 -0400] Allowing up to 100 client connections per host.
    I [15/Aug/2008:00:15:45 -0400] Using policy "default" as the default!
    I [15/Aug/2008:00:15:45 -0400] Full reload is required.
    I [15/Aug/2008:00:15:45 -0400] Loaded MIME database from '/etc/cups': 34 types, 39 filters...
    I [15/Aug/2008:00:15:45 -0400] Loading job cache file "/var/cache/cups/job.cache"...
    I [15/Aug/2008:00:15:45 -0400] Full reload complete.
    I [15/Aug/2008:00:15:45 -0400] Listening to 127.0.0.1:631 on fd 2...
    I [15/Aug/2008:00:15:45 -0400] Listening to /var/run/cups/cups.sock on fd 3...
    I [15/Aug/2008:00:22:58 -0400] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=5013)
    I [15/Aug/2008:00:23:06 -0400] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=5042)
    I [15/Aug/2008:00:23:06 -0400] Started "/usr/lib/cups/daemon/cups-deviced" (pid=5043)
    I [15/Aug/2008:00:23:20 -0400] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=5109)
    I [15/Aug/2008:00:23:30 -0400] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=514
    I [15/Aug/2008:00:23:35 -0400] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=516
    I [15/Aug/2008:00:23:35 -0400] Started "/usr/lib/cups/daemon/cups-deviced" (pid=5169)

  6. #5
    Just Joined!
    Join Date
    Dec 2007
    Posts
    86
    Hi Jay
    Is that /var/log/cups/error_log (and /var/log/cups/acces_log) you are showing me?


    http://localhost:631/admin/printers usually shows one error message at the time, and the most relevant one, so that you don't get too confused.
    You should try to troubleshoot that one, first.

    I suggest, you go to /dev/lp0 (parallel port), for a try, if that is your port for the printer, than make the port executable, and check the permissions, and the ownership.

    But if your printer is connected via USB (quasi a USB printer), than you would most likely have to look inside of /dev/bus/usb/004/002 (USB port) and do the same check.

    If you go to KMenu, Print System, Print Manager, Jobs (card), you are able to see, if, and which print jobs get queued (unprinted jobs).

    All relevant information that you can retrieve from KMenu and from your file system, you can access easier via the CUPS page (your personal printer) in Internet: you switch back and for between "Administration" and "Printer".

    I also recommend to email the developer of your printer driver (is it maybe Mr. Till Kamppeter?): He might be able to give you some good hints and advice.

    Last, but not least: Check in the "Add Printer Wizard", by remembering, what you had configured, if you had chosen in "Local Port Selection" the right "Local System".

    If you say, that the printer does print, when you plug it in after Startup ( I think, you mentioned such a thing in your other thread about the mouse not working properly), this might just be something like a "manual workaround" for a wrong configured/added printer.

    What you could do: Is reinstall your printer, and try to find the correct Local System for your printer.

    However, "Local Port Selection" should show you in USB a port, and maybe even a printer item which you can choose.

    If you are able to set up your printer via a parallel port, with a parallel cable, instead of via USB port, with a USB cable, I recommend doing that. Data transfers via parallel cables and ports might tend to cause less problems and work better, in some cases.

    If your PC is new, or if you have built it yourself as custom made, you will have to be patient, anyway, till your motherboard works better and better with your Linux-operation system.

    Your system is probably quite unstable: But it will do a lot of positive work by self detecting devices, etc, and by putting settings right, etc., and then get more stable. Your own configurations and downloaded and installed applications, etc., will add to the stabilization of your system. Or just get more unstable, if you do some disadvantageous changements/settings.

  7. #6
    Just Joined!
    Join Date
    Aug 2008
    Location
    Detroit area
    Posts
    13

    Printer issues

    Okay,
    Grandebasta, to answer one of your questions, the errors I post were from the site http://localhost:631/admin/log/error_log, and I only copied about ten percent of it. Each time I try a test page, I get a LOT more. The site still tells me my printer is not connected even though it is showing up in /dev/bus/usb/1 right after I replug the usb or turn it on and off. The test page says "processing" forever. I also plugged it into the usb port that I know is working fine. My pc is an old 2.6 Ghz single core Pentium that I built 3 or 4 years ago. It runs too slow for comfort with xp, but screams right along with Mepis 7. I literally have hundreds of cd's here from linux distros I've tried in the past ten years or so and spend a lot of time bragging up linux to anyone who will listen, so this printer thing is kind of a bummer. I keep exploring my system and the internet for the answer because as you know, it'll probably end up being one simple setting somewhere, but nothing so far.
    Does this give you any clues:
    When I select Mepis at the boot screen, the first thing to come up is:
    hub 1-0:1.0 cannot enable port 2 .....maybe usb cable is bad
    hub 1-0:1.0 cannot enable port 6 .....maybe usb cable is bad
    each message shows 3 times.
    I'll read all comments again to see if I missed any of the good suggestions.
    Later,
    jaybee

  8. #7
    Just Joined!
    Join Date
    Dec 2007
    Posts
    86
    Hi Jay
    When you are at localhost:631, at the adminstration page, you can click top right on the "Printer" button: That will bring you to your printer settings page. On that page you should see only one error message, in big letters.

    The USB-ports going from your PC seem to be USB 1.0, or USB 1.1 version.
    Your Printer though, has USB 2.0 version.
    For a device to be able to work, there is always a upstream connection and a downstream connectoin.

    To make a long story short:... USB 1.1 does not match with USB 2.0.

    You either get a newer PC, or a older printer, for the right match. Or maybe there do exist some sort of adapters, which can combine both USB versions, but I have never heard about such a solution.

    Your mouse and printer do get detected, indeed, because one stream works: The upstream from your Host-port to your external device (mouse and printer). But the port does not get the downstream, for the reason I explained, and therefor can not connect to the printer or to the mouse.

    However, by plugging in the device, after booting up your PC, you seem to be working your self around the problem, and the system is making no differnce anymore, between the different USB versions.

    Edit>

    If you are able to combine printer and PC with a parallel cable, you should be done with that constellation/combination.

  9. #8
    Just Joined!
    Join Date
    Aug 2008
    Location
    Detroit area
    Posts
    13

    printer

    The printer has usb or ethernet only. Ethernet has been a pain with this printer as well (linux and windows). What really bugs me is the fact that the printer works perfectly, and quite fast, on the same usb ports with Windows xp. I just hate the think that I have to give up on the setup with linux when xp does it so well. Until I find the fix, I will have to reboot to xp when I need to print documents or photos. However, if linux cannot do 1.0 to 2.0 , perhaps I should look at getting a usb 1.0 to 2.0 adapter. I don't know how well they work, but I have seen them for sale. I guess I could also see what happens with the driver cd and wine......Anyway, I'll mess with the other printing options other than cups to see what happens since that is how I got the only test page to print so far.
    Thanks again my friend, for all your great advice. I learned a few things from you. I'll keep this open for a couple days just in case.
    jaybee

  10. #9
    Just Joined!
    Join Date
    Aug 2008
    Location
    Detroit area
    Posts
    13

    Tadaaaaa !!

    If at first you don't succeed, keep on suckin til ya do suck seed. I think in my case USB stands for Use Something Better. I decided to give ethernet another try and it worked. I'm stickin' with it.
    Thanks for the advice......forum experts who take the time totally rock !!!
    Keep rockin'

    jaybee

  11. #10
    Just Joined!
    Join Date
    Dec 2007
    Posts
    86
    Hello Jay
    I understand that your printer is now up and running the way it should, on your Linux-partition, with a ethernet connection. Good. Interesting, that it USB had problems...

    Please mark your tread as "Solved", if you think that it is solved. Thank you.


    Quote:

    Question: Which Broadband Modem Interface is Better - Ethernet or USB?

    Most broadband modems support two kinds of network connections - Ethernet and USB. Both interfaces serve the same purpose, and either will work in most situations. Users can re-configure their modem between Ethernet and USB whenever needed, but both interfaces cannot be connected simulateously. So which is better?

    Answer: Ethernet is the preferred option for connecting a broadband modem, for the following reasons:

    * Ethernet is technically more reliable than USB for networking. You are less likely to experience dropped connections or sluggish response time to your modem when using Ethernet over USB.

    * Ethernet cables can reach a longer distance than USB cables. A single Ethernet cables can run most anywhere within a home (technically up to 100m (328 feet), while USB cable runs are limited to approximately 5m (16 feet).

    * Ethernet does not require the installation of device driver software, while USB does. Modern operating systems like Microsoft Windows XP will be capable of automatically installing drivers for many broadband modems. However, the procedure varies on different operating systems and not all systems will be compatible with a given brand of modem. USB drivers can also slow down the overall performance of older computers. In general, a device driver is an additional installation step and source of potential problems that you need not worry about with Ethernet.

    From:
    Ethernet vs USB - Which Broadband Modem Interface is Better?

    Look for more articles of this kind:

    Ethernet vs USB - Help - Virgin Media

    ethernet versus USB - Google-Suche


    Have a nice weekend. Enjoy.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •