Hi,

My mandrake linux can't detect my soundcard(soundMax) and wirelesscard (realtek 8180L) automaticly. So I strumbled the web in search for the drivers, and I succeded!!
For the realtek driver I have to change the include path in the makefile. I changed in /usr/include/linux/ (i don't know if it's correct).

When I try to run the makefile, I get an error:

"You should not include /usr/include/{linux,asm}/ header files directly for the compilation of kernel modules.
glibc now uses kernel header files from a well-defined working kernel version (as recommended by Linus Torvalds) These files are glibc internal and may not match the currently running kernel. they should only be included via other directly include <linux/*.h> of <asm/*.h> as well.

To build kernel modules please do the following:
o Have the kernel sources installed

o Make sure that the symbolic link /lib/modules/`uname -r`/build exists and points to he matching kernel source directory

o Now copy /boot/vmlinuz.version.h to /lib/modules/`uname -r`/build/include/linux/version.h

o When compiling, make sure to use the following compiler option to use the correct include files:
-I/lib/modules/`uname -r`/build/include
instead of
-I/usr/include/linux

Please adjust the Makefile accordingly"


When I try to install my soundcard driver I get the same message.
How do I make a symbolic link and what is the kernel source directory?

Thanks,

Arjan