Find the answer to your Linux question:
Results 1 to 5 of 5
i'm not sure how much this issue has been addressed, but it would be awesome if someone could shed some light on the scenario. i've got a brand new samsung ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2008
    Posts
    3

    crt monitor worked fine, new lcd doesn't (but is fine in windows)


    i'm not sure how much this issue has been addressed, but it would be awesome if someone could shed some light on the scenario.

    i've got a brand new samsung 245bw lcd monitor. i'd been using my 19" nec crt monitor for the past 7 years and decided an upgrade was in order.

    in windows, it works flawlessly. yet under any distro of linux i've tried (just installed opensuse 11 today, which is what i'll stick with for now), it flickers and/or turns off for a few seconds with any rapid screen movement. sometimes before it shuts off for a few seconds, i will see what looks like poor resolution, coloured 1px lines scrambling across the screen, then it goes black...coming back a second or 2 later.

    the most obvious guess i had was a refresh setting was off. but i can't seem to get it to work normally under any refresh rate.

    here's my specs:
    -samsung 245bw monitor, currently running @ 60hz, 1920x1200
    -ati all in wonder 8500 (ancient, i know)
    -ATI R200 QL driver

    again, it runs flawlessly under windows....but on linux, it's rough. real rough. any thoughts?

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Hello, and welcome to the forums!

    I have that exact monitor and it's worked fine under every Linux distribution that I've tried it with. However, I do use nVidia cards with official nVidia drivers, so can't really speak regarding any output from ATI cards and drivers.

    If you can, post your xorg.conf file here so that any ATI users can check it over, looking for anything that might be wrong.
    oz

  3. #3
    Just Joined!
    Join Date
    Oct 2008
    Posts
    3
    Quote Originally Posted by ozar View Post
    Hello, and welcome to the forums!

    I have that exact monitor and it's worked fine under every Linux distribution that I've tried it with. However, I do use nVidia cards with official nVidia drivers, so can't really speak regarding any output from ATI cards and drivers.

    If you can, post your xorg.conf file here so that any ATI users can check it over, looking for anything that might be wrong.
    thanks for the reply. should also mention that i can run the monitor via analog cable, no problem...then i just have crap for resolution (it doesn't let me get anywhere near the 1900x1200 that i'm after. here's the contents of my xorg.conf....




    # /.../
    # SaX generated X11 config file
    # Created on: 2008-10-04T16:51:06-0400.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "Files"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    Option "ZapWarning" "on"
    EndSection

    Section "Module"
    Load "glx"
    Load "type1"
    Load "extmod"
    Load "dbe"
    Load "freetype"
    Load "dri"
    EndSection

    Section "InputDevice"
    Driver "kbd"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbLayout" "us"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    EndSection


    Section "InputDevice"
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Buttons" "14"
    Option "Device" "/dev/input/mice"
    Option "Name" "Logitech USB Receiver"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection


    Section "Monitor"
    DisplaySize 518 324
    HorizSync 30-60
    Identifier "Monitor[0]"
    ModelName "SAMSUNG SYNCMASTER"
    Option "DPMS"
    Option "PreferredMode" "1920x1200"
    VendorName "SAM"
    VertRefresh 50-60
    UseModes "Modes[0]"
    EndSection


    Section "Modes"
    Identifier "Modes[0]"
    Modeline "1920x1200" 154 1920 1968 2000 2080 1200 1203 1209 1235 -hsync +vsync
    EndSection


    Section "Screen"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection


    Section "Device"
    BoardName "R200 QL"
    BusID "1:0:0"
    Driver "radeon"
    Identifier "Device[0]"
    Screen 0
    VendorName "ATI"
    EndSection



    Section "ServerLayout"
    Identifier "Layout[all]"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Option "Clone" "off"
    Option "Xinerama" "off"
    Screen "Screen[0]"
    EndSection


    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

    Section "Extensions"
    EndSection

  4. $spacer_open
    $spacer_close
  5. #4
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    I don't know that it will help, but your horizontal sync and vertical refresh rates are quite different from mine:

    HorizSync 30-81

    VertRefresh 56-75
    oz

  6. #5
    Just Joined!
    Join Date
    Oct 2008
    Posts
    3
    Quote Originally Posted by ozar View Post
    I don't know that it will help, but your horizontal sync and vertical refresh rates are quite different from mine:
    i don't know much about refresh rates, so i probably shouldn't have screwed around, but i'm pretty sure those rates you listed were the same default rates that i had mine set at, and i lowered them. right now what i've been doing to get by is restarting linux with the dvi cable plugged in, then switching the cable running to my computer it to analog after it boots up. so far, so good....but this is obviously not ideal.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •