Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 29
Awesome! Thanks a bunch, guys! I'll go ahead and build those in and see what goes on after, and let you know what kind of progress I make! Thanks again!...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023

    Awesome! Thanks a bunch, guys! I'll go ahead and build those in and see what goes on after, and let you know what kind of progress I make!

    Thanks again!
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  2. #12
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Well, I got the modules and drivers installed properly this time. The output of lsmod now shows the modules that I need. Ran alsaconf, and alsamixer. Also, /etc/modprobe.conf now shows the proper entries... but still no sound coming through!
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  3. #13
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    So the modules are loaded and when you ran alsaconf it "found" it as a non legacy device? If so, then the module you need is present. Did it want snd-intel8x0 or snd_hda_intel ? If running alsaconf asked if you wanted to edit modprobe.conf to add it, then run alsamixer to set volume levels. What works for me is to install Xmms and use it to play mp3 or ogg files. Once I got that going on, everything else works too.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  4. #14
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    alsaconfig did indeed find it as a non-legacy. I ran alsamixer, adjusted the volume... still no go. By the way, you and Mike were correct. It wanted snd-intel8x0. But when I tried to install Xmms, it told me that xmms could not be found. I tried with Xmms2 and it gave me
    Code:
    -- Packages where install failed
    xmms2
    So I'll see what I can do about that tomorrow.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  5. #15
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Really Jay, just any old player will do. I just am a stalwart Xmms guy as it is very minimal and does the job. I've not used Xmms2. I think I remember having problems with it before. Should be as easy as:
    Code:
    prt-get depinst xmms
    ...should be in "contrib." Did you prt-get for xmms or xmms2? By the way, can you post the results of lsmod so we can see if all the related modules are present for sound?
    Linux Mint + IceWM Registered: #371367 New Members: click here

  6. #16
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Good idea with the modules Dan, he could be missing one or more modules, I know mine uses about 16 modules, I just haven't figured out which ones are the only ones I need or if I actually need them all.

    Jay, did you try alsaunmute? I adjusted my settings just like you are doing, but it still did not work until I issued that command and then it was so loud I almost had a cardiac. I didn't even know the command existed until I was browsing through the alsa directory. But then again, this is Fedora, you may not have alsaunmute.
    Last edited by MikeTbob; 11-23-2008 at 03:48 PM. Reason: typos
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  7. #17
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Hey guys! Dan, when I did prt-get for xmms, I was told that it could not be found. And I made sure that contrib is enabled. So I did a locate for it, and came up with Xmms2. Not getting a footprint mismatch or anything... just a failed install on it. But here is the output of lsmod.
    Code:
    bash-3.2$ /sbin/lsmod
    Module                  Size  Used by
    usb_storage            57604  0 
    snd_intel8x0           26780  0 
    snd_ac97_codec         86688  1 snd_intel8x0
    ac97_bus                2944  1 snd_ac97_codec
    uhci_hcd               20108  0 
    snd_pcm                60548  2 snd_intel8x0,snd_ac97_codec
    snd_timer              17284  1 snd_pcm
    3c59x                  37288  0 
    mii                     5248  1 3c59x
    thermal                13468  0 
    ppdev                   7428  0 
    usbcore               105456  3 usb_storage,uhci_hcd
    button                  7056  0 
    snd                    39060  4 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
    snd_page_alloc          8200  2 snd_intel8x0,snd_pcm
    processor              28296  1 thermal
    parport_pc             32956  0 
    parport                29000  2 ppdev,parport_pc
    evdev                   7936  0
    Mike, I tried alsaunmute... no go.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  8. #18
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Strange as I have xmms in my contrib which should be the exact same as yours. Have you recently updated your ports?
    Code:
    ports -u
    Afterward, check in /usr/ports/contrib and see if xmms is there. If you don't have regular xmms after doing a ports update we'll both be in the Twilight Zone.

    Your modules appear to be all in order. Also, I don't think we have alsaunmute. It's not on mine either. Are all the inputs "up" and unmuted when running alsamixer?
    Linux Mint + IceWM Registered: #371367 New Members: click here

  9. #19
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023

    Progress... of sorts!

    I found a part of the problem. The last time I had updated my ports was before I remembered to enable contrib. So I did that, and got Xmms installed. Ran alsaconf one more time and made sure that nothing was muted... all looks good. But still no sound... unless I actually login to the system as root. So while I know everything is loaded properly, it doesn't help the current situation as I still get nothing as a regular user. And I can't seem to get it set so that I can run alsaconf or alsamixer as a regular user
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  10. #20
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    I'm pretty sure I ran into this same thing when trying to configure sound. So you DO get sound as root? It's of course a permission problem. Let me R&R (Research and remember) and I'll get back shortly. By the way, running alsaconf as root is the only thing needed. Be back shortly.... suspect and thinking I remember it's merely a "group" problem.

    Edit: Yes, I believe that's what it is. Assuming your usename is "jay," as su do:
    Code:
    adduser jay audio
    To make sure it "took," see what groups jay is a member:
    Code:
    groups jay
    Here are the groups I'm in by comparison:
    Code:
    wheel audio video scanner cdrom usb vboxusers plugdev users
    You may need to add yourself to groups video and plugdev if being a member of audio group alone doesn't do it. Try that and see. You may also need to change permissions on the audio devices so group "audio" can use them...
    Code:
    chmod -R 0660 /dev/snd
    Last edited by Dapper Dan; 11-25-2008 at 11:22 AM.
    Linux Mint + IceWM Registered: #371367 New Members: click here

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •