Find the answer to your Linux question:
Results 1 to 6 of 6
Hi All; I've installed Fedora 10 on a new Dell M6400 laptop with an nvidia card and a 1920x1200 17" screen I'm running KDE I installed the rpmfusion repos, then ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Posts
    38

    Fedora 10 Display resolution issues


    Hi All;

    I've installed Fedora 10 on a new Dell M6400 laptop with an nvidia card and a 1920x1200 17" screen

    I'm running KDE

    I installed the rpmfusion repos, then I installed kmod-nvidia

    Next I ran nvidia-xconfig

    If I run system-config-display under the "Hardware" tab I can set the monitor to "LCD Panel 1920x1200"
    However under the "settings" tab the max I can choose is 1600x1200

    Below is my xorg.conf.

    Thanks in advance


    # cat /etc/X11/xorg.conf
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig: version 1.0 (buildmeister@builder5 Tue Nov 4 17:18:57 PST 2008

    # Xorg configuration created by livna-config-display

    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "Screen0" 0 0
    InputDevice "Mouse0" "CorePointer"
    InputDevice "Keyboard0" "CoreKeyboard"
    EndSection

    Section "Files"
    ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
    ModulePath "/usr/lib64/xorg/modules"
    EndSection

    Section "ServerFlags"
    Option "AIGLX" "on"
    EndSection

    Section "InputDevice"
    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/input/mice"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"

    # keyboard added by rhpxl
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105+inet"
    Option "XkbLayout" "us"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    ModelName "LCD Panel 1920x1200"
    HorizSync 31.5 - 74.5
    VertRefresh 56.0 - 65.0
    Option "dpms"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "nvidia"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "AddARGBGLXVisuals" "True"
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    Section "Extensions"
    Option "Composite" "Enable"
    EndSection

  2. #2
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Under the Monitor section, subsection Display, you may need to add something along the lines of
    Code:
    SubSection "Display"
             Depth         24
             Modes        "1920x1200"
    EndSubSection
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Posts
    38
    Still no luck. I did "test" the video card by installing CentOS and I got 1920x1200 straight away - even without installing the nvidia driver.

    Thoughts?

  4. $spacer_open
    $spacer_close
  5. #4
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023

    Post

    It's been a little while since I booted up to Fedora. Let me get back to you after looking into it a bit.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  6. #5
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Still no luck. I did "test" the video card by installing CentOS and I got 1920x1200 straight away - even without installing the nvidia driver.
    Compare the contents of xorg.conf files of CentOS and Fedora. Post both files here, if possible.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #6
    Just Joined!
    Join Date
    Jul 2005
    Posts
    38
    I've made great progress, but still have one remaining issue.

    I installed the driver from the nvidia site that matches my card (sort of). My box has the Quadro FX 3700 M (mobile) card, I found a driver for the FX 3700 (not the M) and it helped significantly.

    I ran through the nvidia setup (at run level 3) and it compiled a new driver into my system. The nvidia install also wrote a new xorg.conf file for me.


    So here's where it leaves me:

    The new xorg.conf file finally gives me true 1920x1200 resolution, however running the new xorg.conf file I get no glx (no glx screen savers and no Fedora 10 KDE desktop effects)

    and the resolution reverts back to the old resolution where the system reports
    it as 1920x1200 but it's clearly something more like 1280x800

    at this point I'd rather have true 1920x1200 than glx effects if I can't have
    both. However if anyone has any thoughts I'd appreciate any input on how to
    get both.


    I found that the new xorg.conf file does not reference 'nvidia' as the driver (wierd since the nvidia installer created it)

    I initially tried this:

    I replaced this section :
    Section "Device"
    Identifier "Videocard0"
    Driver "vesa"
    EndSection


    with this:
    Section "Device"
    Identifier "Videocard0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "Quadro FX 3700M"
    EndSection


    However once I restarted the X server the system reverted back to the old resolution where the system (xrandr) reports that it's running at 1920x1200 but its really more like 1280x800


    So I have one config file that gives me true 1920x1200 resolution and another that gives me desktop effects & openGL screen savers but at a resolution more like 1280x800.

    Below are the 2 config files:


    This one (my current xorg.conf) gives me "true" 1920x1200

    # Xorg configuration created by livna-config-display

    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "Screen0" 0 0
    InputDevice "Mouse0" "CorePointer"
    InputDevice "Keyboard0" "CoreKeyboard"
    EndSection

    Section "Files"
    ModulePath "/usr/lib64/xorg/modules"
    EndSection

    Section "ServerFlags"
    Option "AIGLX" "on"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/input/mice"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"

    # keyboard added by rhpxl
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105+inet"
    Option "XkbLayout" "us"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    ModelName "LCD Panel 1920x1200"
    HorizSync 31.5 - 74.5
    VertRefresh 56.0 - 65.0
    Option "dpms"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "vesa"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "AddARGBGLXVisuals" "True"
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    Section "Extensions"
    Option "Composite" "Enable"
    EndSection










    This one gives me the glx screensavers and desktop effects but I only get about
    1280x800 screen resolution even though the system (xrand) reports that it's
    running at 1920x1200

    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings: version 1.0 (buildmeister@builder5 Tue Nov 4 17:19:39
    PST 2008

    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig: version 1.0 (buildmeister@builder5 Tue Nov 4 17:18:57
    PST 2008

    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    EndSection

    Section "Files"
    FontPath "/usr/share/fonts/default/Type1"
    EndSection

    Section "Module"
    Load "dbe"
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx"
    EndSection

    Section "ServerFlags"
    Option "Xinerama" "0"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/input/mice"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"

    # generated from data in "/etc/sysconfig/keyboard"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbLayout" "us"
    Option "XkbModel" "pc105"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Seiko"
    HorizSync 30.0 - 75.0
    VertRefresh 60.0
    Option "DPMS"
    EndSection

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "Quadro FX 3700M"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TwinView" "0"
    Option "metamodes" "nvidia-auto-select +0+0"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection


    Thanks...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •