hi people

I'm running debian on an AUSUS P4C800 mainboard, and recently purchased a maxtor SATA drive.

with the kernel that came with the install (2.4.25-1-386) I can access my drive at /dev/hde. transfer rate is as good as with the IDE / Dual ATA drive, say around 60MB/sec

I tried compiling a 2.6.8.1 kernel, and when I use this one I can't see my hd anywhere, neither on /dev/hde, nor on /dev/sd

when I try to compile 2.6.8.1 with /boot/config-2.4.25-1-386 I get this at boot:
Code:
VFS: Cannot open root device "hda5"  or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on unknown-block(0,0)
/ is on a reiserfs partition (hda5), reiserfs support is built hard in the kernel (and 2.4.25- still manages to boot on it while it's built as a module)

I've tried using a config file from someone who apparently managed to get his SATA drive on the intel ICH5 controler, and that didn't work out.

I've tried adding all options to my kernel, but compiling crashes due to errors

the config I use now for my 2.6.8.1 is here, it works great except for the lack of support of my sata drive and i2c hardware sensors (why?)

does some-one out here have anymore ideas of things I could try, or tests I could run to see JUST HOW my 2.4 kernel manages to access my SATA drive?