Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    No output from cat /dev/input/mouse


    Hi,

    I`m writing a program to read data from a USB mouse.

    In order to do that, I need to specify the correct device path for the mouse.

    Now although my mouse is working fine and i get the correct mouse movement,
    I am not getting any output from "cat /device/input/mouse1" on the console
    when i move the mouse around. (I am doing this so that i know i am using the correct
    device path)

    I know that mouse1 is the correct node as when I plug in the mouse and remove it,
    "mouse1" appears and disappers respectively from /dev/input/ . Also when
    I run cat /proc/bus/input/devices, the Handler item tells me that the correct node
    is mouse1.

    But just in case I was wrong, I have also tried mouse0, mouse2 and mice but i dont get any output.

    However, when I do cat /dev/input/mouse1 on my desktop PC, it does give me output but with
    the same mouse in my laptop, there is no output. My PC has Ubuntu 7.10 and laptop Ubuntu 8.10.

    Can anyone tell me why I`m not getting any output. The mouse is working perfectly otherwise and thats whys baffling me.

    Btw, the lapti@p isbrand new and wasjust installed with Ubuntu 8.10

    Thanks

  2. #2
    -->
    Install gnome-device-manager. Run the program, find your "pointing devices" and it will show you the proper device:



    You may have to add extra code to get this portable to other peoples' computers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •