Find the answer to your Linux question:
Results 1 to 3 of 3
I got an old NEC Ready-series computer with aftermarket ISA ethernet card for use as a Samba/CUPS server. The original win95 installation and a puppylinux CD did not recognize the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2008
    Posts
    6

    [SOLVED] 3 different distros do not recognize either of my ethernet cards


    I got an old NEC Ready-series computer with aftermarket ISA ethernet card for use as a Samba/CUPS server. The original win95 installation and a puppylinux CD did not recognize the card, and neither did a Debian net install CD nor an Ubuntu Server CD. I ordered a PCI NIC that claims to support Linux right on the box and that doesn't get seen either. However, the PCI winmodem is seen, and the AGP Voodoo 3DFX works fine.

    I have attached a plaintext file with every piece of debugging info I can think of (the contents of /sys/devices/pci0000:00, the contents of /dev, dmesg, uname -a, and lspci -vvvnn.)

    I have no idea what's going on, I tried the PCI NIC in another rig and it works just fine, Ubuntu detects it without a problem. I don't have another computer with an ISA port. Google doesn't turn up anything. The driver that came with the NIC doesn't help.


    Does anyone have any idea what's going on and how I can fix it?


    ISA card is a D-link DE-220P. The PCI card is a StarTech ST100SW. At this point, if I could get either of them working, that would be excellent.


    EDIT: How can a Linux forum not allow .gz attachments?
    Attached Files Attached Files

  2. #2
    tpl
    tpl is offline
    Linux User
    Join Date
    Jan 2007
    Location
    cleveland
    Posts
    478
    looks to me like a hardware problem: you have 8
    devices (lspci) but no network controllers: so the
    card is either not installed, or not recognized as
    being on the bus. If the computer is a PC
    (i.e. non-laptop) perhaps you could try another
    slot, or clean some contacts.
    the sun is new every day (heraclitus)

  3. #3
    Just Joined!
    Join Date
    Dec 2008
    Posts
    6
    Acting on this advice, I checked to make sure that the NIC was installed firmly in its slot (it was.) Then I realized that the 56k WinModem was recognized, but I didn't need it. I removed the WinModem and moved the NIC to that slot instead, and now it works!

    I hate it when a solution is "too obvious." Thanks for making me try it anyway!

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •