Find the answer to your Linux question:
Results 1 to 5 of 5
I'm having a problem getting xorg.conf to display properly. I'm on a Dell Optiplex 755 using an ATI Radeon HD 2400 XT and two Dell 1908WFP monitors. The OS is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Posts
    4

    XORG.CONF with ATI Driver Problem


    I'm having a problem getting xorg.conf to display properly.

    I'm on a Dell Optiplex 755 using an ATI Radeon HD 2400 XT and two Dell 1908WFP monitors. The OS is RHEL5, kernel 2.6.18.el5PAE. It's on an isolated lan.

    The driver file I'm using is 'ati-driver-installer-8-12-x86.x86_64.run'. The installer runs without error; fglrx-install.log shows that the kernel modules generate without any problems. Afterwards, I run the fglrx install shell as instructed, and then run aticonfig --initial. After a log out and login, I run the ATI Catalyst Control Center and set the monitors up for a big desktop spread, and after another logout/login, everything looks good.

    At this point, fglrxinfo says;
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Radeon HD 2400 XT
    OpenGL version string: 2.1.8304 Release

    Here's where the problem comes in. When I reboot the computer, the display goes black, and the only way I can correct it is to force a reboot, bring it up in single user mode, and either delete xorg.conf or modify it to use the vesa driver instead of the fglrx driver.

    Not having a "Screen0" LeftOf "Screen1" setup in xorg.conf isn't important right now. I'll settle for even a single display after a reboot.

    Here's my xorg.conf after the aticonfig --initial
    ----------------------------------------------------------------------
    # Xorg configuration created by system-config-display

    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "aticonfig-Screen[0]-0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    EndSection

    Section "Files"
    EndSection

    Section "Module"
    EndSection

    Section "InputDevice"
    Identifier "Keybard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]-0"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "radeon_tp"
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]-0"
    Driver "fglrx" (this is what I change to vesa to get the display back)
    BusID "PCI:1:0:0" (this is correct)
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1440x900" (the rest left out for brevity)
    EndSubSection
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device "aticonfig-Device[0]-0"
    Monitor "aticonfig-Monitor[0]-0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

  2. #2
    Just Joined!
    Join Date
    Jan 2009
    Posts
    4

    XORG.CONF with ATI Driver Problem

    More info - depending on how I try to boot up, I get different results. If I telinit 6 or shutdown -r, the display comes up black with no mouse cursor, and I can't determine what state the display is in, whether it's big desktop or not. If I boot up in single-user and X -config /etc/X11/xorg.conf, I get a black screen, but I get an "X" mouse cursor and can see that the displays are set to big desktop (left and right). If I boot up in single-user and run startx or do a telinit 5, I make it all the way to a great-looking desktop, but it starts all over as soon as I reboot.

    I know, you're all saying "if it hurts when you do this, don't do it."

    Xorg.0.log doesn't show any errrors at all. Everything is reporting successful initialization. Just some warnings about the AIGLX 3D driver near the end of the log that I would think shouldn't be causing the display to go black.

    Anyone else ever see this problem?

  3. #3
    Just Joined!
    Join Date
    Jan 2009
    Posts
    4

    XORG.CONF with ATI Driver Problem - (FIXED)

    Turns out the problem was DRI. I had to turn it off. The "Device" section reads like this;

    Section "Device"
    Identifier "Device0" (or whatever your ServerLayout is pointing to)
    Driver "fglrx"
    BusID "PCI:1:0:0"
    Option "no_dri" "on" <--- just add this
    EndSection

    That's it!

  4. #4
    Just Joined!
    Join Date
    Jan 2009
    Posts
    4

    XORG.CONF with ATI Driver Problem - SOLVED

    No, that wasn't it. Turning off DRI turned off the ATI graphics acceleration, so fglrx went back to using the Mesa driver. After wasting another day trying out all the xorg.conf options I could possibly think of, I gave up.

    Solution: I bought a EVGA e-GeForce 8600 GTS for $90 with a $45 mail-in rebate, downloaded the 'NVIDIA-Linux-x86-180.22-pkg1.run' driver installer, and had it up and running within minutes. Comparing the performance to the ATI Radeon HD 2400 XT, glxgears ran over 300% faster on the 8600 GTS.

    I'll never use ATI on Linux again.

  5. #5
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Glad you got it sorted in the end, just caught your thread now. I have always used nVidia or Intel where possible to avoid the ATI problems. Hopefully the new RadeonHD drivers will yield better results for ATI users in the future

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •