Find the answer to your Linux question:
Results 1 to 6 of 6
I can't get the sound driver to initialize. Every time I log in, it gives me this message: Sound server informational message: Error while initializing the sound driver: device /dev/dsp ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    8

    Sound driver.


    I can't get the sound driver to initialize. Every time I log in, it gives me this message:


    Sound server informational message:
    Error while initializing the sound driver:
    device /dev/dsp can't be opened (No such device)
    The sound server will continue, using the null output device.


    I have Aureal 8830 media card, and am running Mepis. Right now, the only way I get sound from anything on the internet, I download it to Linux, transfer it to Windows, boot into Windows, and listen. Thanks.

  2. #2
    Linux User nalg0rath's Avatar
    Join Date
    Sep 2004
    Location
    Stockholm
    Posts
    303
    Have you probed the device at all? What is your modules.conf entry?

    The device maybe is being used by another program or maybe it crashes at boot. Look for the driver with:
    Code:
    # ll /dev/dsp

  3. #3
    Just Joined!
    Join Date
    Sep 2004
    Location
    UMR
    Posts
    14
    from a terminal, do "cat /proc/asound/cards"

    if you have a card detected by alsa, itll show up there. if nothing is there, you probably need to load a module. try "modprobe snd-au8830"

    if none of this works, it would help to know your distro and kernel version. use "uname -r" to get your kernel version if you dont know it already

  4. #4
    Just Joined!
    Join Date
    Aug 2004
    Posts
    8
    Thanks for trying. I tried nalg0rath's idea before it was suggested. That didn't work, so I tried iamben's idea. It said I didn't have permission. I, the root user. I ended up getting the sound card replaced with a Sound Blaster Live! 5.1 card. It works perfectly, and has since I first put it in, so it was probably a hardware malfunction. I appreciate your help, though.

    The only problem now is that sound doesn't work in Windows, and the only drivers specifically written for the card that I downloaded are written for audio cards, rather than media cards. I got them off of the Creative web site, and am now angry at Creative for sucking.

  5. #5
    Just Joined!
    Join Date
    Jun 2004
    Posts
    45
    Well, if that's the case, cant see any harm in having both cards installed. If one is not detected, it should be fine.

    Likewise, my wireless card wont work in Linux, so I ran a 50' cable to my room and have a ethernetcard installed. Works fine.

    Try that and see what happens.

  6. #6
    Just Joined!
    Join Date
    Feb 2005
    Posts
    1
    try www.kxproject.com for the best creative drivers. The original drivers just suck. You will see how powerfull the emu10k1 chip on your card can be.
    I also have troubles installing my creative 4.1 sound card. I installed the alsa drivers, but I get the same error as posted first. If anuyone could help..

    cat /proc/asound/cards -- there is no such directory

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •