Find the answer to your Linux question:
Results 1 to 4 of 4
I'm running Backtrack 3 (kernel 2.6.x) in VMware Workstation 6.0.3 *edit* also tried in booting from CD and USB */edit*. Getting an error when attempting to install a driver for ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2009
    Posts
    3

    Driver install error in Backtrack 3 :X


    I'm running Backtrack 3 (kernel 2.6.x) in VMware Workstation 6.0.3 *edit* also tried in booting from CD and USB */edit*. Getting an error when attempting to install a driver for my Linksys WUSB600N wireless USB stick (Ralink chipset).

    I've been through 3 different drivers so far all displaying the same error. The Ralink driver direct from their website and 2 versions of the hirte and nemesis version of that driver. All 3 have worked for other people on that same distro but not for me. :P

    Here's the details:

    bt 1 # make
    make -C tools
    make[1]: Entering directory `/tmp/1/tools'
    gcc -g bin2h.c -o bin2h
    make[1]: Leaving directory `/tmp/1/tools'
    /tmp/1/tools/bin2h
    cp -f os/linux/Makefile.6 /tmp/1/os/linux/Makefile
    make -C /lib/modules/2.6.21.5/build SUBDIRS=/tmp/1/os/linux modules
    make: *** /lib/modules/2.6.21.5/build: No such file or directory. Stop.
    make: *** [LINUX] Error 2
    bt 1 # make install
    make -C /tmp/1/os/linux -f Makefile.6 install
    mkdir: cannot create directory `/etc/Wireless': File exists
    make[1]: Entering directory `/tmp/1/os/linux'
    rm -rf /etc/Wireless/RT2870STA
    mkdir /etc/Wireless/RT2870STA
    cp /tmp/1/RT2870STA.dat /etc/Wireless/RT2870STA/.
    install -d /lib/modules/2.6.21.5/kernel/drivers/net/wireless/
    install -m 644 -c rt2870sta.ko /lib/modules/2.6.21.5/kernel/drivers/net/wireless/
    /sbin/depmod -a 2.6.21.5
    make[1]: Leaving directory `/tmp/1/os/linux'
    bt 1 # iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.


    Any suggestions? Thanks guys

    P.S.
    I'm a full on linux newb, just started yesterday. Done a massive amount of reading and have gotten to this point but now i'm stuck! :P

  2. #2
    Just Joined!
    Join Date
    Mar 2009
    Posts
    3
    The quest continues...

    I've tried booting the kernel from CD and USB now and receive the same error when attempting to install the drivers so this cuts out Vmware as the source.

    Also re-downloaded Backtrack 3 in 2 different versions and all drivers to rule out corrupt source code.

    I attempted everything on two seperate computers which have had their hardware tested recently. No luck :X

  3. #3
    Just Joined!
    Join Date
    Mar 2009
    Posts
    3
    Anyone? :P Just need a leg in the right direction.

  4. #4
    Linux Newbie TrashOverride's Avatar
    Join Date
    May 2004
    Location
    @home...soon in your homes ;) /usr/src/bulgaria
    Posts
    162
    SourceForge.net: ndiswrapper

    this installs windows drivers for wifi to linux

    To install the driver using NdisWrapper, follow these instructions:

    1. Open a terminal window (Applications -> Accessories -> Terminal). In the window, type the following to switch to the directory containing the driver files:


    Code:
          cd /home/<username>/Desktop/driver
    Replace <username> with your own username.

    2. To install the driver, type the following:


    Code:
         ./ndiswrapper i filename.inf
    Replace filename.inf with the name of the .inf file you discovered in the previous steps.

    3. Next, type the following:

    Code:
          su
            ndiswrapper m 
           joe /etc/modules
    This will open the modules configuration file for editing. On a new line at the bottom, add the following:

    Code:
          ndiswrapper
    Ensure you press Enter after adding the line.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •