Find the answer to your Linux question:
Results 1 to 6 of 6
Hi everyone! I finished my instalation of a linux in my computer and the problem is that the cursor of the mouse appears in the KDE desktop but doesn't work ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Posts
    1

    The mouse doesn't work!!


    Hi everyone!
    I finished my instalation of a linux in my computer and the problem is that the cursor of the mouse appears in the KDE desktop but doesn't work and it was working in the instalation process. what can i do to put the mouse working. i'm new to linux. I have a dual boot with windows intalation and the mouse works fine in windows. it's a logitech 3 buttons 1 it's a wheel.

    Sorry for my bad english and thanks for the attention
    Raul Silva

  2. #2
    Just Joined!
    Join Date
    Sep 2004
    Posts
    1

    same thing

    hi,
    Im experiencing the same problem, maybe we could fix the problem together.
    you said you have a logitec mouse, well, Ive got an Intelli mouse explorer.
    what kind of a motherboard do you have? I got an ASUS

    I tried to fix some X.org (/etc/X11/xorg.conf) settings but it appears not to be the reason...

  3. #3
    Just Joined! coolguy-in's Avatar
    Join Date
    Sep 2004
    Posts
    21

    Re: The mouse doesn't work!!

    What distro you are using???????????????????

    Try "setup" to reconfigure your mouse.

  4. #4
    Just Joined!
    Join Date
    Oct 2004
    Posts
    7
    What kernel are you running?
    # uname -r

    Do you have a PS/2 mouse (small round connector with 6 pins)?

    If you have a 2.6.* kernel with a PS/2 mouse, it is possible that either the kernel has the "psmouse" kernel module built-in, in which case your mouse freezes even though X starts, or you need to run
    # modprobe psmouse

    If you run this and afterwards it starts working, you should add a line with the word "psmouse" to the file /etc/modules.

    There seems to be some common problem with 2.6 kernels that stops PS/2 mice working when "psmouse" is built-in. In this case there are a few options:
    1. Use a USB mouse (also possible if you have a USB mouse with a PS/2 adapter, you just remove it).
    2. Re-compile your kernel to have psmouse as a module.
    3. Use a 2.4 kernel, since they're so much easier (IMHO).

    Hope this helps! If this is the situation you are in, there should be plenty of information on the 'net already.

  5. #5
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817

    Re: same thing

    Quote Originally Posted by hendrik
    I tried to fix some X.org (/etc/X11/xorg.conf) settings but it appears not to be the reason...
    xorg.conf would be the first place I would look: much easier than changing the kernel. hendrik, did you restart X after making the changes? Lots of things in Linux can be changed "on the fly", but not the X configuration: it requires shutdown of the X server and restart (reboot would work, too, but it's not necessary). Maybe you should post the part of xorg.conf dealing with the mouse: it will start with a line
    Code:
    Section InputDevice
    And like coolguy-in says, "what distro?"
    /IMHO
    //got nothin'
    ///this use to look better

  6. #6
    Just Joined!
    Join Date
    Dec 2006
    Posts
    1
    Quote Originally Posted by innodonni
    If you have a 2.6.* kernel with a PS/2 mouse, it is possible that either the kernel has the "psmouse" kernel module built-in, in which case your mouse freezes even though X starts, or you need to run
    # modprobe psmouse

    If you run this and afterwards it starts working, you should add a line with the word "psmouse" to the file /etc/modules.
    Thanks! I had this problem and your suggestion was exactly what was needed!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •