Find the answer to your Linux question:
Results 1 to 4 of 4
I posted a similar thread on the Vector Linux (the OS I was trying to install when I came across this issue) forums, but they haven't been much help thus ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2009
    Posts
    3

    Partition trouble


    I posted a similar thread on the Vector Linux (the OS I was trying to install when I came across this issue) forums, but they haven't been much help thus far. I thought I'd try my luck here.

    I'm a bit new to Linux. The last time I tried anything was about a year and a half ago. I successfully installed Arch with the help of a friend. That laptop died, and since then, I've been Linuxless.

    I'm currently dealing with a Compaq Presario 1236. AMD K6 @ 233mhz, 190Mb of RAM, 4Gig HDD. This is the oldest computer I've ever used, and it's been giving me a pretty hard time. Being unfamiliar with Linux doesn't help much.

    I popped the VL Light 5.9 disc in, got to the second menu of the installation, and decided to have a go at partitioning the drive to get started. My problem is.. Cfdisk and fdisk aren't cooperating with the hard drive. It wouldn't let me choose an option to partition the drive. I tried opting for a new partition table, that didn't work. I chose the option for the existing partition table, and that didn't work. The screen just flashes once, quickly. There's no response. I took out the installation CD, popped in Knoppix, and used Gparted to partition the drive. It seemed to work fine. I wiped it completely, set aside space for swap and root. There were no issues, and the commands went through (so it seemed). I went back to VL, and the same **** occurred. On both Knoppix and the VL installation, I receive errors for Cfdisk and fdisk. Fdisk is "unable to open the drive," and Cfdisk encounters a fatal error.

    I ran a utility for the hard drive to verify it's functionality, and all went well. It was some bootable utility HP support directed me to a little while ago.

    Someone on the VL forums advised that I do fdisk -l and show him the output. There was no output. The HDD seems to be ignored. I don't understand this because Windows 98 was running perfectly fine before I took it off to make space for Linux.

    Sorry for the long post. If you've read this far, I appreciate it. If anyone has any information for me, I'd be very grateful. As aforementioned, I'd consider myself a nub, but I'm patient and willing to learn, so throw whatever you've got at me.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,525
    Well, after 3 weeks I suspect you have either found the solution or have given up... . I'm not familiar with Vector Linux, but this sort of thing happens when a system is using non-standard controller hardware, which is often the case with older Compaq systems. You say that gparted on your knoppix disc seemed to be OK with the system. Have you tried to install knoppix on it instead of VL?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Mar 2009
    Posts
    3
    I gave up, lol. I installed Damn Small Linux successfully, but it was unbelievably slow. I never installed Knoppix, or even speculated the idea, due to DSL's staggeringly annoying speed. I assumed another live OS would do just as badly. I wanted more of a concrete, HDD distribution. Thank you for the reply, man.

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,525
    Well, due to the really small amount of memory on your system, it was probably hitting the swapper pretty hard. Which desktop were you running? You might try one of the light-weight ones like TWM or the more modern XFCE. Also, remove any running daemons that are not needed. At least you got it working. Then you can start tuning it until it performs reasonably well. Of course, you can always turn off the GUI all together and run from the command line, which will reduce overhead by a very large margin...
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •