Find the answer to your Linux question:
Results 1 to 4 of 4
Motherboard Gigabyte GA-EX58-UD4P GIGABYTE - Product - Motherboard - Specification - GA-EX58-UD4P (rev. 1.0) North Bridge: Intel X58 Express Chipset South Bridge: Intel ICH10R Audio: Realtek ALC889A codec High Definition ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Posts
    49

    Can't Get Linux Installed / Running - "Intel i7" Based System


    Motherboard

    Gigabyte GA-EX58-UD4P
    GIGABYTE - Product - Motherboard - Specification - GA-EX58-UD4P (rev. 1.0)

    North Bridge:
    Intel X58 Express Chipset

    South Bridge:
    Intel ICH10R

    Audio:
    Realtek ALC889A codec
    High Definition Audio

    LAN:
    Realtek 8111D chip

    Storage:
    SATA


    CPU

    Intel i7 920


    Video Card
    NVIDIA - GeForce GTX 260


    I can boot from a live CD and all is well, but when I go to install it fails, and even if it does seem to install, it refuses to boot. I've tried many 32 and 64 bit distros, but all fail. Windows XP 32 bit and Vista 64 bit work perfectly.

    I suspect that it may have something to do with the either the North Bridge chipset, South Bridge chipset, or both, but most likely the South Bridge storage management (IDE/SATA), but I'm not sure. I suspect that the Linux kernel is not communicating with my chipset I/O.

    I'm not a very experienced Linux user, but I have successfully installed and operated Linux on older systems. I have to assume that the current Linux kernel does not support these current computer technologies, because on the older systems Linux installed and worked fine.

    Any help with this will be much appreciated!

  2. #2
    Linux Newbie Charles4809's Avatar
    Join Date
    Nov 2008
    Location
    Utrecht, NL
    Posts
    138
    Try changing the BIOS settings for SATA. Once Linux is installed you can change it back.
    Linux needs a Sata driver (libata) to communicate. It's present in every modern distro.
    Charles
    ASUS EEE Box B202, Atom 270 1,6GHz, 1 GB, HDD 80GB, XP-SP3 / PinguyOS
    Asus EEE PC 901 with Bodhi-Linux

  3. #3
    Linux Engineer b2bwild's Avatar
    Join Date
    Jul 2008
    Location
    Behind You!
    Posts
    1,108
    Is there any specific error you get while install?
    Never make any misteaks.

    Read my Blog at --> Penguin Inside Subscribe Feed

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,159
    The i7 chips are pretty new - this one was released only at the end of 2008. It is likely that you need to get a BIOS update for this system to run Linux. When I installed Linux on my system with the then brand new Penryn chips and the Intel S5000XVN motherboard, I had to get an updated BIOS from Intel before I could install Linux. Check on the Gigabyte web site for a BIOS update. From what I read, they are at BIOS version F7, which was only released at the end of last month, so it is likely that your motherboard is running an earlier version. You can download it from this page: GIGABYTE - Support&Download - Motherboard - BIOS - GA-EX58-UD4P (rev. 1.0)

    Also, you should set the BIOS to used the enhanced sata mode, NOT legacy, otherwise it won't recognize more than 4 drives in the system.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •