Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    no sound after upgrading from FC6 to FC9


    After the upgrade I'm deperately unable to make the sound work.

    The hardware is ASUS P5WDH deluxe motherboard.

    lspci gives:
    00:00.0 Host bridge: Intel Corporation 82975X Memory Controller Hub (rev c0)
    00:01.0 PCI bridge: Intel Corporation 82975X PCI Express Root Port (rev c0)
    00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
    00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
    00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 01)
    00:1c.4 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express Port 5 (rev 01)
    00:1c.5 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express Port 6 (rev 01)
    00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
    00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
    00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
    00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
    00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
    00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
    00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
    00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
    00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
    00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
    01:02.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
    01:03.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
    02:00.0 SATA controller: JMicron Technologies, Inc. JMicron 20360/20363 AHCI Controller (rev 02)
    02:00.1 IDE interface: JMicron Technologies, Inc. JMicron 20360/20363 AHCI Controller (rev 02)
    03:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit Ethernet Controller (rev 20)
    04:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit Ethernet Controller (rev 20)
    06:00.0 VGA compatible controller: nVidia Corporation NV44 [GeForce 6200 LE] (rev a1)

    the start of Alsa info looks like:


    !!Linux Distribution
    !!------------------

    Fedora release 10 (Cambridge) Fedora release 10 (Cambridge) Fedora release 10 (Cambridge) Fedora release 10 (Cambridge)


    !!Kernel Information
    !!------------------

    Kernel release: 2.6.27.21-170.2.56.fc10.i686
    Operating System: GNU/Linux
    Architecture: i686
    Processor: i686
    SMP Enabled: Yes


    !!ALSA Version
    !!------------

    Driver version: 1.0.17
    Library version:
    Utilities version: 1.0.19


    !!Loaded ALSA modules
    !!-------------------
    After the upgrade I'm deperately unable to make the sound work.

    The hardware is ASUS P5WDH deluxe motherboard.

    snd_hda_intel


    !!Sound Servers on this system
    !!----------------------------

    Pulseaudio:
    Installed - Yes (/usr/bin/pulseaudio)
    Running - Yes

    Jack:
    Installed - Yes (/usr/bin/jackd)
    Running - No


    !!Soundcards recognised by ALSA
    !!-----------------------------

    0 [Intel ]: HDA-Intel - HDA Intel
    HDA Intel at 0xfebfc000 irq 19


    !!PCI Soundcards installed in the system
    !!--------------------------------------

    00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
    01:02.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)


    !!Advanced information - PCI Vendor/Device/Susbsystem ID's
    !!--------------------------------------------------------

    00:1b.0 0403: 8086:27d8 (rev 01)
    Subsystem: 1043:81d8

    alsaunmute gives:

    Unknown hardware: "HDA-Intel" "Realtek ALC882" "HDA:10ec0882" "" ""
    Hardware is initialized using a guess method

    and iecset audio on:

    control "IEC958 Playback Default" (index -1) not found

    I tried several option for snd-hda-intel, but without succes.

    Any clue?
    Thanks

  2. #2
    Linux Engineer b2bwild's Avatar
    Join Date
    Jul 2008
    Location
    Behind You!
    Posts
    1,108
    Post out put of this command
    # cat /proc/asound/card0/codec#* | grep Codec
    Have you googled Realtek ALC882 with Linux?
    there are many people having trouble with it.

  3. #3
    Here is the listing of /proc/asound:

    -r--r--r-- 1 root root 0 avril 18 11:17 id
    -rw-r--r-- 1 root root 0 avril 18 11:17 oss_mixer
    dr-xr-xr-x 3 root root 0 avril 18 11:17 pcm0c
    -r--r--r-- 1 root root 0 avril 18 11:17 stream0
    -r--r--r-- 1 root root 0 avril 18 11:17 usbbus
    -r--r--r-- 1 root root 0 avril 18 11:17 usbid

    There is no codec*.
    I will look for ALC882
    Thanks for your help

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •