Find the answer to your Linux question:
Results 1 to 9 of 9
I've got a laptop running Kubuntu 9.04. Prior to upgrading to 9.04 from 8.10, the fglrx video drivers were "working" (there were some glitches, but it worked)... prior to the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Location
    North Dakota, USA
    Posts
    14

    ATI Video Drivers [Mobility FireGL V5200]


    I've got a laptop running Kubuntu 9.04. Prior to upgrading to 9.04 from 8.10, the fglrx video drivers were "working" (there were some glitches, but it worked)... prior to the upgrade, I was able to turn on Desktop Effects and get things like the cube working.

    After the upgrade, the laptop would lock pretty much any time I would try to do something graphical, such as resizing an application (I could open Pipewalker, try to resize, and immediately freeze the system).

    Taking the queue from the local LUG, I installed envyng and used the text-based installer to install the ATI drivers (fglrx). I rebooted and got to the point where the X server starts, then it would freeze with a doubled-up screen that had lines through it.

    Is there some other drivers I need?

    Here's info from lspci:

    00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
    00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port (rev 03)
    00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
    00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
    00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
    00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
    00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 02)
    00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
    00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
    00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
    00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
    00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
    00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
    00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
    00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
    00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
    01:00.0 VGA compatible controller: ATI Technologies Inc M56GL [Mobility FireGL V5200]

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    I don't use ATI cards, so I'm not too up on this but the problem as I understand it is that the newer fglrx drivers (Catalyst 9.4) dropped support for some ATI cards, and the older fglrx drivers (Catalyst <= 9.3) are not compatible with the new xorg 1.6

    Looking at the release notes for Catalyst 9.4, the FireFL V5200 is not listed as supported. It is listed in Catalyst 9.3.

    The option is to use the open source radeonhd driver - I don't know if 3D is supported for your card yet, though it is for some cards, or downgrade to xserver-xorg 1.5 and use the 9.3 catalyst release.

  3. #3
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    More info from a KDE developer blog.

  4. #4
    Just Joined!
    Join Date
    Aug 2006
    Location
    North Dakota, USA
    Posts
    14
    Cool. I've installed the packages and even rebooted (successfully, I might add). How do I test to see which video driver is installed?

    Drivers in Linux have always baffled me. Either it works or it doesn't... that's all I know.

  5. #5
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Generally your video driver will be listed in the xorg.conf file. (Located at /etc/X11/xorg.conf) I know at some point, though, that file stopped being required, though you can still create one to tweak various settings. Usually you still need one for the Catalyst and Nvidia drivers, though, to get 3D acceleration working. I'm not sure if Jaunty has one by default or not.

    Did you uninstall the drivers you had before installing the older versions?

    lsmod will list loaded modules. You can look for fglrx there.

    You can generate a new xorg.conf file in Debian based systems with sudo dpkg-reconfigure xserver-xorg.

    There is a section of the file where you can specify your driver. It will look similar to this
    Code:
    Section "Device"
    	Identifier  "Card0"
    	Driver      "fglrx"
    	VendorName  "ATI Technologies Inc"
    	BoardName   "Radeon Mobility X1400"
    	BusID       "PCI:1:0:0"
    EndSection
    The catalyst driver also comes with a tool to modify an existing xorg.conf file, called aticonfig. Run aticonfig --help from the command line for options.

    There are a couple of lines the fglrx driver needs, that I don't believe are generated by aticonfig. You need a Screen section with a default depth of 24, and a DRI section with Mode 666 in it. Looks something like this
    Code:
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Card0"
    	Monitor    "Monitor0"
    	DefaultDepth	24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
     
    Section "DRI"
    	Mode 0666
    EndSection
    The Screen section should be there if you generated an xorg.conf with dpkg-reconfigure, just check that Depth is set to 24. The DRI section you may have to add entirely.

  6. #6
    Just Joined!
    Join Date
    Aug 2006
    Location
    North Dakota, USA
    Posts
    14
    Okay, I have no flgrx in lsmod. Here's what I find in lsmod that seems to refer to my video card in some way:::

    output 11008 1 video
    video 25360 0
    There is no aticonfig utility anywhere on my system. As for the xorg.conf, it looks distressingly baren:::

    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    EndSection

    Section "Module"
    Load "dri"
    Load "GLcore"
    EndSection

    Section "Device"
    Identifier "Configured Video Device"
    Driver "vesa"
    EndSection
    (yes, that's the whole thing, minus all the comments at the top). As far as I know, I've completely removed all drivers associated with fglrx from my system (I used "envyng -t" to remove it after my system hard locked). I've installed the radeon & radeonhd packages, so those would presumably also have appeared in my xorg.conf.

    I am terrible at working with the X configuration file directly. Your help is most appreciated!

  7. #7
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    The xorg.conf file won't change itself if you install a new driver. You'll have to change it by hand or use one of the automated tools.

    Currently, it looks like you're using the generic "vesa" driver. It's ok that the file is sparse, as I said, the newer xorg doesn't need the configuration file, assuming everything is being detected ok, so you can get away with just a few things in there to tweak. Back this one up and regenerate the file.

    Code:
    sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
    sudo dpkg-reconfigure -phigh xserver-xorg
    Take a look and see what driver it lists then. If ati or radeonhd, then either restart the computer, or you can just restart X. See how it goes.

  8. #8
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Hmm, I realize that you may need to kill X, before messing with xorg.conf. Can't remember if this is the case. Probably safest anyway.

    Press CTRL+ALT+F1
    It will take you to a console login. Log in.
    Type
    Code:
    sudo /etc/init.d/gdm stop
    sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
    sudo dpkg-reconfigure -phigh xserver-xorg
    sudo /etc/init.d/gdm start

  9. #9
    Just Joined!
    Join Date
    Aug 2006
    Location
    North Dakota, USA
    Posts
    14
    Thankfully, I didn't have to drop to a console to make the changes to xorg.conf, as my consoles were fubar: it looked like it was trying to display 1600x1024 on a 42-inch screen, and could only show me the top left corner.

    After following the latest set of instructions, the problem with my consoles has gone away. Most of the video-related sluggishness seems to have disappeared, such as crawling when it fades the screen when I click the "logout" button (the background fades as the infamous logout dialog appears).

    It appears that I can now turn on desktop effects, and the cube seems to work well (I would think it's just about the most graphically intensive operation). Pipewalker graphics also are very nice again, so things have improved.

    I guess the only problem I have left is with OpenGL graphics. Since ATI has decided to drop support for my particular video card, I wonder if I will ever get that back... any pointers are certainly welcome.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •