Find the answer to your Linux question:
Results 1 to 9 of 9
I just got a new laptop, DELL E6500 and pretty much everything is working just fine. I have installe Linux Mint what is based on Ubuntu. The speakers are working ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2007
    Posts
    7

    USB speakers not working


    I just got a new laptop, DELL E6500 and pretty much everything is working just fine. I have installe Linux Mint what is based on Ubuntu. The speakers are working but I dont get them as loud as with windows. But that is the same with every other distribution. But now I got some USB speakers from Logitech. In Windows they are working just fine. How I get them to work with Linux? Any ideas??? I heard I need to blacklist the internal sound card and pc speakers, and explicitly load the module for the USB speakers. How I blacklist that? Not familiar with that.

  2. #2
    Just Joined!
    Join Date
    May 2007
    Posts
    7
    By the way. The USB speakres are V20 Notebook Speakers from Logitech.

  3. #3
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Howdy. I was the one who gave you the advice on blacklisting the modules for you internal sound card, which is what worked for me to get my USB speakers working.

    We need to know what your sound card is, and what modules are loading first. Please open a terminal and post the output of:
    Code:
    lspci
    then
    Code:
    lsusb
    then
    Code:
    lsmod
    Enclose the output of each command in code tags as described here.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2007
    Posts
    7
    Output for lspci
    00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
    00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
    00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)
    00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
    00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
    00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
    00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
    00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
    00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
    00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
    00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
    00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
    00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
    00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
    00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
    00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
    00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
    00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
    00:1f.2 RAID bus controller: Intel Corporation Mobile 82801 SATA RAID Controller (rev 03)
    00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
    01:00.0 VGA compatible controller: nVidia Corporation Quadro NVS 160M (rev a1)
    03:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ba)
    03:01.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 04)
    03:01.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 21)
    03:01.3 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev ff)
    0c:00.0 Network controller: Intel Corporation PRO/Wireless 5300 AGN [Shiloh] Network Connection


    Output for lsusb
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 005 Device 002: ID 0a5c:5801 Broadcom Corp.
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 005: ID 413c:8156 Dell Computer Corp.
    Bus 003 Device 004: ID 413c:8158 Dell Computer Corp.
    Bus 003 Device 003: ID 413c:8157 Dell Computer Corp.
    Bus 003 Device 002: ID 0a5c:4500 Broadcom Corp.
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


    Output for lsmod
    Module Size Used by
    nls_iso8859_1 12032 2
    nls_cp437 13696 2
    vfat 18816 2
    fat 58272 1 vfat
    binfmt_misc 16776 1
    ppdev 15620 0
    bridge 56340 0
    stp 10500 1 bridge
    bnep 20224 2
    vboxnetflt 93992 0
    vboxdrv 123048 2 vboxnetflt
    input_polldev 11912 0
    joydev 18368 0
    lp 17156 0
    parport 42220 2 ppdev,lp
    snd_hda_intel 435636 5
    snd_pcm_oss 46336 0
    snd_mixer_oss 22656 1 snd_pcm_oss
    snd_pcm 82948 3 snd_hda_intel,snd_pcm_oss
    arc4 9856 2
    ecb 10752 2
    snd_seq_dummy 10756 0
    pcmcia 44748 0
    iwlagn 100228 0
    iwlcore 93184 1 iwlagn
    snd_seq_oss 37760 0
    snd_seq_midi 14336 0
    snd_rawmidi 29696 1 snd_seq_midi
    led_class 12036 1 iwlcore
    btusb 19608 2
    snd_seq_midi_event 15104 2 snd_seq_oss,snd_seq_midi
    snd_seq 56880 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_mid i_event
    snd_timer 29704 2 snd_pcm,snd_seq
    snd_seq_device 14988 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi ,snd_seq
    mmc_block 17668 2
    yenta_socket 32396 1
    rsrc_nonstatic 19328 1 yenta_socket
    psmouse 61972 0
    nvidia 7233756 60
    mac80211 217208 2 iwlagn,iwlcore
    video 25360 8
    snd 62628 18 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,sn d_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_de vice
    soundcore 15200 1 snd
    ricoh_mmc 11904 0
    pcspkr 10496 0
    pcmcia_core 43540 3 pcmcia,yenta_socket,rsrc_nonstatic
    sdhci_pci 15232 0
    sdhci 23940 1 sdhci_pci
    serio_raw 13316 0
    dcdbas 15264 0
    intel_agp 34108 0
    agpgart 42696 2 nvidia,intel_agp
    output 11008 1 video
    snd_page_alloc 16904 2 snd_hda_intel,snd_pcm
    iTCO_wdt 19108 0
    iTCO_vendor_support 11652 1 iTCO_wdt
    usbhid 42336 0
    cfg80211 38032 3 iwlagn,iwlcore,mac80211
    ohci1394 38576 0
    ieee1394 94660 1 ohci1394
    e1000e 121136 0
    fbcon 46112 0
    tileblit 10752 1 fbcon
    font 16384 1 fbcon
    bitblit 13824 1 fbcon
    softcursor 9984 1 bitblit

  6. #5
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Did you have the USB speakers plugged in when you did lsusb? I forgot to mention you should - it detects USB devices. I just wanted to make sure the device was being recognized properly by the system.

    To continue, type: sudo gedit /etc/modprobe.d/blacklist-snd-intel
    This will open a new file. Add to the file the line
    Code:
    blacklist snd_hda_intel
    and save. That actually should do it. Plug in your USB speakers and restart. If it doesn't, you may need to explicitly list the USB module: sudo /etc/modprobe.conf and add snd_usb_audio to the file.

  7. #6
    Just Joined!
    Join Date
    May 2007
    Posts
    7
    Strange things has happened. After I did that now I don't have any sound at all. Even not with regular external speakers and neven not after I deleted that file again what I have created earlier. Don't know right now how I get the sound back. Since the final version of Linux Mint 7 is coming out in a week or so, I will do a new install then. I guess the best would be to keep a second version of Linux on a seperate partition just to do testing like I did with the speakers. If you have any idea to get the sound back, please let me know. Else I will come back after I have re-installed Linux. Thanks so far.

  8. #7
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Did you try adding snd_usb_audio to /etc/modprobe.conf?

    As things are, with the USB speakers plugged in, can you post the output of lsusb and lsmod.

    To get the sound back as is, yes, remove the file, or just comment out the line by adding a # at the beginning. I know sometimes if the driver for the pc speakers (which produces those annoying beeps and blips) loading first can block sound from the normal sound card. There's a way to set it to load after the regular driver, but I don't remember how, I'd have to check. You can blacklist it as well, if you like, it should be pcspkr. It's a little strange to me that sound did not return once you removed that file. To load the internal card sound driver by hand, do
    Code:
    sudo modprobe snd_hda_intel
    .

    You should also check in the pulse audio settings, that you have it to the right device. Look under preferences, there should be an audio devices section, or something along those lines. Open that up, and you have some drop down menus to select the sound device. Hmm, with the previous setup, that may have been the problem - needing to select the USB speakers there. I don't use pulseaudio, so I'm not sure of its quirks.

    If that all fails, you can also try and set up your card again with the alsa config tool.
    Code:
    sudo alsaconf

  9. #8
    Just Joined!
    Join Date
    May 2009
    Posts
    21
    Use VLC media player for all your audio, and route the audio output to your USB speakers - which are probably at /dev/dsp1.

    Then Google: linux mint firefox how to make sound dev dsp1, for making audio work within Firefox webpages.

  10. #9
    Just Joined!
    Join Date
    Nov 2010
    Posts
    32

    I know this is an old thread but

    If I blacklist the internal speakers, what if I want them to work as soon as the usb speakers are unplugged?

    (trying to use Logitech S-150 USB Speakers



    Quote Originally Posted by reed9 View Post
    Howdy. I was the one who gave you the advice on blacklisting the modules for you internal sound card, which is what worked for me to get my USB speakers working.

    We need to know what your sound card is, and what modules are loading first. Please open a terminal and post the output of:
    Code:
    lspci
    then
    Code:
    lsusb
    then
    Code:
    lsmod
    Enclose the output of each command in code tags as described here.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •