Find the answer to your Linux question:
Results 1 to 7 of 7
Hi, I am using Ubuntu 8.04 Hardy Heron on an AMD Athlon 1.2 GHz processor . I'd like to save the data on my home partition as I have the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    11

    usb hard drive unmounted automatically


    Hi,
    I am using Ubuntu 8.04 Hardy Heron on an AMD Athlon 1.2 GHz processor .
    I'd like to save the data on my home partition as I have the impression the hard drive hosting it is going to "die" soon .
    I've bought a USB Sata hard drive of 320 GB and actually the volume of data I'd like to transfer is far lower, around 15 G .

    I've formatted two primary partitions on the drive .
    One is ext2 (30 G) and the other one is 260 G with reiser fs .
    I use the following command to save my datas :

    sudo nice -n 19 rsync -P -av --exclude=".*/" /home/cedric/ /mnt/home/cedric/


    Here is the problem :

    A few files get transfered and each time, it ends with I/O error messages and the device file /dev/sdc2 representing the reiserfs partition gets deleted .
    Listing /dev directory, it appears that the two partitions are renamed as /dev/sdd1 and /dev/sdd2 .

    I've tried to mount /dev/sdd2 instead of /dev/sdc2, but the same scenario repeats : I/O errors, /dev/sdd2 deleted and creation of /dev/sde2, etc...

    What do you think about this ?

    Thanks a lot for your help,

    CÚdric

  2. #2
    Linux Enthusiast meton_magis's Avatar
    Join Date
    Oct 2006
    Location
    arizona
    Posts
    699
    I think you need a replacement for your external hard drive. Also just FYI, USB and SATA are both busses; you can't have a usb sata hard drive. You may have a sata hard drive in an enclosure that converts the bus to USB, but that's about as close as you can get.

    If that is the case, either your external hard drive is having problems, your enclosure is having problems, or your USB connector on your motherboard (or tower, which connects to a header on your motherboard) is having a problem. If you can use another flash drive or hard drive on the same usb port, it is fine, so it would be your external hard drive, or it's enclosure. I would test out different configurations, but it sounds like your hard drive is going offline quickly, and going back online (hence sdc being deleted, and going to sdd or sde or whatever, it is being bounced around as a "new" drive). It deffinately sounds like a hardware problem though.
    New to the internet, technical forums, or the hacker / open source community??
    Read this to learn good posting habits http://www.catb.org/~esr/faqs/smart-questions.html

    RHCE for RHEL version 5
    RHCT for RHEL version 4

  3. #3
    Just Joined!
    Join Date
    Sep 2008
    Posts
    11
    You are right about the hard drive, it's a SATA drive with a USB interface .
    I am going to do some tests on somebody else PC to see how things turn out there .

    Thanks for your help

  4. #4
    Just Joined!
    Join Date
    Sep 2008
    Posts
    11
    Well, after these tests I still don't know what to think .

    I transfered via rsync almost all the partition with some errors after having plugged the inner and outer hard-drive on a friend's machine.
    There were no /dev/sde or /dev/sdd files created .

    I forgot to say that my motherboard is old (2001) and has a USB 1.1 controller
    Could it be the source of my problems ?

  5. #5
    Linux User
    Join Date
    May 2009
    Location
    Big River, Sask, Canada
    Posts
    342
    That may be it. Sata drives can easily max out a usb 1.0 link.
    Registered Linux User #420832

  6. #6
    Just Joined!
    Join Date
    Sep 2008
    Posts
    11
    I am going to install a PCI to USB 2.O card to check if it's possible to keep my
    old motherboard, otherwise, I'll send it to museum !

  7. #7
    Just Joined!
    Join Date
    Sep 2008
    Posts
    11
    Fine
    Thanks to the PCI to USB 2.0 card, now it works !!
    Bye and thanks or your ideas,
    Grokakin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •