Find the answer to your Linux question:
Results 1 to 5 of 5
Hello, I now seem to have the same problem! I have tried everything but to no avail. My 320gb disk only shows 40gb and it's not possible to access the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    3

    Disk Geometry Problem


    Hello,

    I now seem to have the same problem!

    I have tried everything but to no avail. My 320gb disk only shows 40gb and it's not possible to access the rest of the disk - i have tried all the software tools i could find. The data is important to me...

    Do you remember your workaround by any chance???
    I know it's been a while but any help would be greatly appreciated!


    Thank you very much!
    Alexander

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Welcome to the forums!

    TestDisk and PhotoRec are good tools for partition table and/or file recovery. If you haven't already tried them, you can find them both on the Parted Magic LiveCD should you wish to give them a go to see if they will work for you. Lots of other handy to have tools reside on the liveCD.

    You can also find out more about TestDisk and PhotoRec on their website:

    TestDisk - CGSecurity
    oz

  3. #3
    Just Joined!
    Join Date
    May 2009
    Posts
    3
    Hello, thanks for the tip... but I already tried Testdisk to no avail!

    I can change the drive geometry manually with Testdisk and it finds my partitions during the scan but can't recover or read anything after the drives official 40gb barrier.

    It seems that the drive's firmware has an error - now i somehow need to convince it to change its cylinders...

  4. #4
    Linux User
    Join Date
    Dec 2007
    Location
    Idaho USA
    Posts
    362
    Just want to be sure, the 320gb hdd was working on the current comp it is now connected to ?

    What brand/model is the hdd ? Is it a internal or external hdd ? SATA or IDE ? Is it a linux or windows hdd ?

    It seems that the drive's firmware has an error
    there is a company that provides some hardware and program that they say can rewrite the firmware on one brand of hdd but I do not remember company name. I think it was posted at Operating Systems - Windows BBS , where some one was looking for help in useing the hardware , in the past 6 months.

  5. #5
    Just Joined!
    Join Date
    May 2009
    Posts
    3
    yeah, same computer... it's a samsung hm320ji 2.5" sata with 2 ntfs partitions.

    problem is that the firmware now says that it has less cylinders. i have exactly the same model here so i can compare the 2 geometries.

    it happened like this:
    i set a password in the bios for the hdd. then one day after not using it for a while, i took it out of the laptop, connected it through a usb-external case to another computer to transer the data - but forgot that there was this password. I connected it and tried to mount it in windows xp... didn't work, so i remembered the password and put it in the laptop again to erase the password... which worked.

    But somewhere in between those things the hdd-firmware must have been confused and did the horrible deed of lowering the cylinder count.

    There is even a tool from Samsung and some russian tool to set the drive geometry but it just won't do - i always get an error when i try to save the geometry...

    it's supposed to be chs 38913 but it only thinks it has 1913. i can send it back to samsung for a replacement but then the data would be lost.


    thank you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •