Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 20 of 20
Haha yeah as matter of fact I did click on the file like 4 times. I thought a window would pop up and show me the execution but it didn't...4 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jul 2007
    Posts
    14

    Haha yeah as matter of fact I did click on the file like 4 times. I thought a window would pop up and show me the execution but it didn't...4 times in a row . Anyway, I'm not sure if I edited the rt2870 driver these last few days but I highly doubt it. Here are the output of those commands

    ifconfig
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:0f:20:1f:07:62
              inet addr:192.168.1.106  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::20f:20ff:fe1f:762/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:2060 errors:0 dropped:0 overruns:0 frame:0
              TX packets:2335 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:889293 (889.2 KB)  TX bytes:425835 (425.8 KB)
              Interrupt:11 Base address:0xc000
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:24 errors:0 dropped:0 overruns:0 frame:0
              TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:1240 (1.2 KB)  TX bytes:1240 (1.2 KB)
    iwconfig
    Code:
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    pan0      no wireless extensions.
    It doesn't seem like I have any sort of ra0. I'm thinking about doing a fresh reinstall of kubuntu to get rid of anything I may have botched up. What do you suggest next?

  2. #12
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You actually could let Kubuntu looks if there is a driver available for your card. I'm not sure exactly where it is on Kubuntu, but look in the menus for something call Hardware Divers (Manager). It may actually list a driver that can be installed.

    According to this blog, it is included in version 9.04. It says it will work, unless you have an unsupported USBID. Unfortunately, it appears that you fall into that category.

    I guess if you really want to get this working, you need to find out how to get it to support your USBID. I downloaded the driver source, and will look to see if there is a way.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #13
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Hey! I found something that may work!

    AAccording to this, you need to make this change:

    Edit the /etc/modules file (as root)
    Code:
    kdesudo kwrite /etc/modules
    If you don't have kwrite installed, you can use a different editor. Then add this to the file.
    Code:
    alias ra0 rt2870sta
    Then, to make ra0 start at each boot, edit this file.
    Code:
    kdesudo kwrite /etc/init.d/rc.local
    Add this line to the end of the file.
    Code:
    ifconfig ra0 inet up
    I want to say that I really am not too sure about that last alteration. The rc.local file is a script, and not a config file. Editing it like this may cause it to not work at all. It may even prevent your system from booting. More research may be needed.
    Please do not send Private Messages to me with requests for help. I will not reply.

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Jul 2007
    Posts
    14
    Yeah, I tried searching in Hardware Drivers and it tells me that there are no drivers available. Sucks...I'm not sure what a USBID is however I suspect that it may have something to do with it.

    Also, when installing the drivers "sudo make" returns a couple errors while "sudo make install" does not. This is what "sudo make" returns in case you're interested. Note: My root driver folder (that I extracted) is on my desktop: /home/alex/Desktop/Driver

    Code:
    make -C tools                                   
    make[1]: Entering directory `/home/alex/Desktop/Driver/tools'
    gcc -g bin2h.c -o bin2h                                      
    make[1]: Leaving directory `/home/alex/Desktop/Driver/tools' 
    /home/alex/Desktop/Driver/tools/bin2h                        
    cp -f os/linux/Makefile.6 /home/alex/Desktop/Driver/os/linux/Makefile
    make  -C  /lib/modules/2.6.28-11-generic/build SUBDIRS=/home/alex/Desktop/Driver/os/linux modules                                                                           
    make[1]: Entering directory `/usr/src/linux-headers-2.6.28-11-generic'                
      CC [M]  /home/alex/Desktop/Driver/os/linux/../../common/crypt_md5.o                 
    In file included from /home/alex/Desktop/Driver/include/rtmp_chip.h:47,               
                     from /home/alex/Desktop/Driver/include/rt_config.h:47,               
                     from /home/alex/Desktop/Driver/include/crypt_md5.h:47,               
                     from /home/alex/Desktop/Driver/os/linux/../../common/crypt_md5.c:27: 
    /home/alex/Desktop/Driver/include/chip/rt2870.h:33:2: error: #error "For RT2870, you should define the compile flag -DRTMP_USB_SUPPORT"                                     
    /home/alex/Desktop/Driver/include/chip/rt2870.h:37:2: error: #error "For RT2870, you should define the compile flag -DRTMP_MAC_USB"                                         
    In file included from /home/alex/Desktop/Driver/include/chip/rt2870.h:41,             
                     from /home/alex/Desktop/Driver/include/rtmp_chip.h:47,               
                     from /home/alex/Desktop/Driver/include/rt_config.h:47,               
                     from /home/alex/Desktop/Driver/include/crypt_md5.h:47,               
                     from /home/alex/Desktop/Driver/os/linux/../../common/crypt_md5.c:27: 
    /home/alex/Desktop/Driver/include/chip/mac_usb.h:171: error: ‘MAX_TXBULK_SIZE’ undeclared here (not in a function)                                                          
    /home/alex/Desktop/Driver/include/chip/mac_usb.h:184: error: expected specifier-qualifier-list before ‘PURB’                                                                
    /home/alex/Desktop/Driver/include/chip/mac_usb.h:210: error: expected specifier-qualifier-list before ‘PURB’                                                                
    /home/alex/Desktop/Driver/include/chip/mac_usb.h:240: error: expected specifier-qualifier-list before ‘PIRP’                                                                
    In file included from /home/alex/Desktop/Driver/include/rt_config.h:56,               
                     from /home/alex/Desktop/Driver/include/crypt_md5.h:47,               
                     from /home/alex/Desktop/Driver/os/linux/../../common/crypt_md5.c:27: 
    /home/alex/Desktop/Driver/include/rtmp.h:645: error: ‘TX_RING_SIZE’ undeclared here (not in a function)                                                                     
    /home/alex/Desktop/Driver/include/rtmp.h:653: error: ‘RX_RING_SIZE’ undeclared here (not in a function)                                                                     
    /home/alex/Desktop/Driver/include/rtmp.h:661: error: ‘MGMT_RING_SIZE’ undeclared here (not in a function)                                                                   
    make[2]: *** [/home/alex/Desktop/Driver/os/linux/../../common/crypt_md5.o] Error 1    
    make[1]: *** [_module_/home/alex/Desktop/Driver/os/linux] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.28-11-generic'
    make: *** [LINUX] Error 2
    Let me try out what you just suggested in the above post. You posted while I was writing this haha.

  6. #15
    Just Joined!
    Join Date
    Jul 2007
    Posts
    14
    alright I'm going to try adding the last line to the second file. Hopefully I'll be able to boot. If not then I guess I'll reinstall and see what happens.

  7. #16
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    The USBID is the 8 number/letter string that is reported in the lsusb command.
    Code:
    ID 0e66:0013 Hawking
    The USBID for this wireless is 0e66:0013.

    If you re-install, install 9.04.
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #17
    Just Joined!
    Join Date
    Jul 2007
    Posts
    14
    Alright, I can restart and everything is fine except Network Manager doesn't see it nor does Linux I don't think. I typed "iwconfig" and there is no ra0 or anything. Not really any different from before adding those lines to those two files. Great...

    I really do appreciate your time and help though.

  9. #18
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Well, no harm done then. But no help either.

    You said that you got errors when compiling the driver, yet I still see it loading. Maybe it didn't compile correctly. I think that the driver is available if you install some packages. It could be in the linux-restriced-modules package, or in the ."backports" package. You may want to look into this method of installing the driver
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #19
    Just Joined!
    Join Date
    Jul 2007
    Posts
    14
    Alright, I'm reinstalling to 9.04 (that was the distro I installed anyway). Hopefully I'll be able to get it working by default but, knowing my luck, my hopes aren't very high.

    If not then I'll just try the method you just posted.

  11. #20
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    One of the problems you are encountering is that the device is not a known USB device, in Linux. There is a file that lists all of the USB Device IDs, found in /var/lib/misc/usb.ids. I opened the file and only found two enties for Hawking:
    Code:
    0e66  Hawking
    	400b  UF100 10/100 Network Adapter
    	400c  UF100 Ethernet [pegasus2]
    I'm not sure how your system is even recognizing your wireless, since it isn't listed. I have the latest version of the usb.ids file.

    I don't know if it will help get the wireless to be recognized, but you could add your device to the list. Maybe something like this:
    Code:
    0e66  Hawking
    	400b  UF100 10/100 Network Adapter
    	400c  UF100 Ethernet [pegasus2]
    	0013  Hawking Hi-Gain Wireless-N [rt2870]
    I have submitted this data to the USB ID Repository, but I don't know what will become of that.

    My hope is that with a proper usb.ids entry, you can use the device as a wireless. But, I suspect that there is more to it than this. Somehow the system needs to identify it as a wireless, so that it can be properly used.
    Please do not send Private Messages to me with requests for help. I will not reply.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •