Find the answer to your Linux question:
Results 1 to 4 of 4
I'm using Opensuse 10.3. Right now when I remove and reattach my external hard drive I have to remount it each time. Is there anyway that I can set it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2009
    Posts
    6

    External Hard Drive Mounting at same path automatically


    I'm using Opensuse 10.3. Right now when I remove and reattach my external hard drive I have to remount it each time. Is there anyway that I can set it to do this automatically and have it mount at the same path each time? I'm using the drive as a backup drive and I am swapping it with another one to keep rotating backups that I can swap between on site and off site. I'd like them both to automatically mount at the same path when plugged in. Is this possible?

    Thanks,

    -Jordan

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,709
    It's possible if you label them and add an entry for that label in /etc/fstab. I do that on my RHEL/CentOS system and it works just fine. I presume that you mean for it to mount to the same mount point, such as /mnt/usb-drv-1 or /media/my-usb-1 - something like that?

    Also, even if you don't put an entry in /etc/fstab, but label the drive, then it will still auto-mount to the same location as /media/label where "label" is the label you gave the drive.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined! kahlil88's Avatar
    Join Date
    Jul 2009
    Location
    Mendocino, CA
    Posts
    25
    Forget about fstab - if hal is setup correctly, it will automatically mount external and optical drives for you. I haven't used SuSE in a long time, but I'll tell you how I got it working on Gentoo:
    Code:
    /etc/init.d/hald start
    and then set it to run at boot:
    Code:
    rc-update add hald default

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2009
    Posts
    6

    Unhappy Swapping still doesn't work

    Quote Originally Posted by kahlil88 View Post
    Forget about fstab - if hal is setup correctly
    What does hal do? I tried setting fstab to add the drives through label rather than device name but that doesn't seem to have worked.

    Thanks,

    -Jordan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •