Find the answer to your Linux question:
Results 1 to 8 of 8
Summary of the whole story, there's a usb hdd, ntfs, I wanted it to be mounted automatically on linux. I've found here , that I could achieve that by adding ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    214

    Unhappy External NTFS hdd works fine on windows, not in linux, despite of doing as KFM said


    Summary of the whole story, there's a usb hdd, ntfs, I wanted it to be mounted automatically on linux. I've found here, that I could achieve that by adding a udev rule:

    Code:
    BUS=="usb", KERNEL=="sd?1", ATTRS{manufacturer}=="Sunplus Technology Inc.", ATTRS{serial}=="0", NAME="%k", SYMLINK="usbhdd1"
    or alternatively

    Code:
    BUS=="usb", KERNEL=="sd?1", SYSFS{manufacturer}=="", NAME="%k", SYMLINK+="usbhdd1"
    Plus "mount -a" on some "rc.local" file, which is usually empty, because it seems that linux usually mounts according to fstab before "connecting" with USB drives. It was also suggested on the topic I saw it.

    I don't know if it's related at all, apparently it worked once, I booted, and it was already mounted on /media/usbhdd. Usually, I have to open KFM and go to that "special" thing, "media:/" and mount over there.

    But I think that one boot after that, it didn't work anymore, and didn't work ever since, except in windows, where it apparently does not have any issue.

    When I try to mount manually on linux, KFM warns about some stuff, and suggests that we do "chkdsk -f" on windows, and reboot twice. I did. Twice. Didn't work.

    I've also tried "ntfsfix", but if I recall it also suggested the same thing KFM suggested.

    So, which option do I have left? Add "force" at the corresponding fstab line? Or there is something less "brute" to attempt first?



    And, besides that. Let's suppose eventually I fix this, is there a more proper way to have an external ntfs hdd that automounts on linux? Or automonting is not recommended at all, due to somewhat poor compatibility with ntfs? I was wondering if the external hdd isn't shutdown as cleanly as it would be if it was an "internal" hdd. Perhaps during/before the shutdown it should be "safely removed", I don't know. I don't recall having any problem at all when I had ntfs partitions on the "internal" hdds, so I guess that being "external" is a factor here.

    I guess that perhaps I can just "fake" an automounting by mounting it via some script like autorstart.sh or xinitrc, before running anything else that would try to access it.


    Many thanks in advance for that.


    [hr]

    Edit: I've just noticed that a "field" on one of the udev rule "version" was empty. I'll try to fill it and see what happens (even though I've disabled the rule anyway, it can't hurt trying).

  2. #2
    Just Joined! eTech97's Avatar
    Join Date
    Jul 2008
    Location
    Winnipeg, Canada
    Posts
    58
    I've seen in other forums; user's with similar problems, all that they had to do, was in windows before they shutdown, was to safely remove the external hard drive in windows.

    Cheers!

  3. #3
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    214
    Just doing that didn't work for me. But maybe it's how it got started, but by not "safely removing" before shutdown within linux. I don't know.

    ...


    I think nobody will believe me, but without clear reason, the whole problem persists, but in an inverted fashion. Now linux reads it ok, but windows will say that the USB device was not recognized.

    Just as earlier, now I can access the files, execute them, etc. Just clicking on the drive icon on kde mediamanager, and it's mounted, just as it should be. In windows though, it does not appear, even if I click on "safely remove" in linux first (which is what I always used to do, except before shutdown, as it wouldn't be actually removed).

    I think I'll try "ntfsfix" from linux.



    It was not that I did nothing and the situation "inverted" all of a sudden, I was trying to mount it in linux many times, changing a bit the udev rule (I've removed the "kernel" part from the smaller one, and then the usbhdd1 symlink was there on /dev/), erasing it -- but this should not really matter, I think; all it apparently does is to create a "stable" symlink name to the dev that can be "sd--whatever" at each time it's connected.

    At one point, however, I could mount it as root, without mount -a, but just "mount /dev/sda1 /media/usbhd", with no other specification. For a normal user, the mount point was locked. But even as root I could not list subfolders above the root folder, it gave me an I/O error.

    At one point I tried the force mount, apparently (as I've read in some forum) all it was supposed to do is to just ignore the warnings and mount anyway. But it didn't work either, actually, it just gave me the same error message and instructions.

    I think that I then unmounted it (never the less, the root folder was still visible on the mount point, for some reason), and plugged it within windows, where it didn't work.

    Plugging back in linux, it did work as it was supposed to, but it still does not work on windows.

    I'm thinking about resizing the partition, format a new one as fat32, copying the things over there, and formatting the remnant ntfs as fat32 too. I guess that much of this has to do with ntfs, but I don't really know.

    I'm a bit uncomfortable with using fat32 too, since I've heart it's even worse than ntfs regarding eventual unexpected energy shortages...




    edit: well, I've just unplugged and plugged it on windows a few more times, and eventually it did work. First it was somewhat worrisome as it would refuse to "safely remove", saying that the device was in use (but of course not saying what was using it), but then I could safely remove after restart. And it still works on linux. I did not plugged it on windows once again, but I guess unless it's something really #$#$#@ mysterious, it should still work there. It's not something I'm deeply trusting will happen, since nothing should have happened in the first place, since I did not do something obviously prone to trouble...

    Alleviating since it's apparently solved, but frustrating since I don't know what happened or how it was solved.

    Now I got to find how to guarantee that it will shutdown cleanly on linux. I guess it has to do with fstab, permissions to normal users to umount, and some script or maybe something more complicated.
    Last edited by the dsc; 08-12-2009 at 11:30 PM. Reason: kinda solved/spell check

  4. #4
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    214
    I'll update what I'm doing and what is going on, even though I don't know exactly how it worked, so it could be a reference just anyone has similar problems.


    Following the apparent solution in the previous post, it was in fact not plainly solved. Two things were happening: 1 - the usb drive would unmount all of a sudden, apparently it was more consistently triggered by a torrent I was downloading via qbittorrent. The message was "I/O error, maybe disk full <or something else I don't remember>".

    If I recall (I really should do logs/notations about these things), at this point, windows (XP) wasn't able to access it anymore, it would not recognize the device. But I'm not totally sure. One thing that happened more than twice during the whole situation was that seldom windows would recognize the device at the first attempt. But sometimes (maybe always) unplugging and replugging a few times would suffice.

    When I tried to mount again (now in linux, after the sudden involuntary umount), I'd receive a message about I/O error on the mount point! It made me suspicious about some of the "internal" hdds being corrupted, so I forcechecked chkdsk, but nothing found (supposing that this is the correct method to find something).

    Googling for I/O error on the mount points and external ntfs hdds at the same time, I've found someone saying that he had it, reformatted the hdd, and then it was completely solved.

    I followed the advice, and apparently it's all fine. (Reformatted, still ntfs, via gparted or qtparted). The torrent is not making the hdd unmount, at least. I didn't try it on a windows computer yet, though.

  5. #5
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    214
    Now it does not work on linux or windows..... :-/

    Once it even didn't fail to work after a brief power shortage, but wasn't working automatically the next time I've turned on the comuputer, even though I've manually unmounted it. I've eventually made it work somehow, but it ended with a I/O error again, and now it will not be recognized by windows even after several attempts, and linux never attributes an "sd" "address" to it. Dmesg says:

    usb 3-2: device descriptor read/8, error -110

    But not long ago it was:

    device descriptor read/64, error -110

    It changed from 64 to 8 apparently after I've tried "modprobe ehci_hcd", as I've found when googling for this phrase.

  6. #6
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,452
    Since you had a power failure, my guess is that the NTFS volume got zapped. Don't know if the hard drive itself is fubar, but it might be. Only recourse is to reformat the drive and tell the system to scan for bad blocks. If it doesn't mount on Windows any longer and Windows disk recovery software doesn't work, then I doubt that anything will be recoverable.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  7. #7
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    214
    Maybe I didn't explain clearly, but after the power failure the hdd was (surprisingly) working normally; mounted automatically and all.

    Only later, the other day that it started to not work properly. Despite of unmounting the hdd manually before turning the power off, on the previous day.

    But perhaps somehow the problem does not appear immediately, I don't know. I think it's unlikely. But it's all very strange.

    I'm hoping the problem has to do with the usb interface, maybe with complicatons due to NTFS. I'll try to install "directly" it in another computer (with windows) and see what happens, whenever I have a chance.

    If it's still working, I think I'll backup everything and make it ext3 anyway.

    I hope the USB adapter isn't somehow able to induce hardware malfunction on the hdd, I'll search if such thing is possible...

  8. #8
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,452
    It's entirely possible that the power failure has caused the USB or disc controller in the external drive to start failing, even though it didn't right away. Heat from a running drive can do that.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •