Find the answer to your Linux question:
Results 1 to 6 of 6
i tried to burn a cd with k3b, but it gave me an error saying there was no device to burn it with. i looked at the settings it had, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Oct 2004
    Location
    127.0.0.1
    Posts
    113

    linux doesnt recognize my burner as a writer


    i tried to burn a cd with k3b, but it gave me an error saying there was no device to burn it with. i looked at the settings it had, and it had my burner as a reader only, and not a write. whats wrong?

  2. #2
    Just Joined!
    Join Date
    Oct 2004
    Posts
    6

    Writer recognition

    Hi,
    I have never used K3b, but would be amazed if it is anything more than a graphic shell for cdrecord.
    From a terminal type "cdrecord -v -scanbus" to show SCSI devices on system
    "cdrecord -v -scanbus dev=ATA" to show ATAPI under 2.6
    or "cdrecord -v -scanbus dev=ATAPI" for ATAPI under 2.4
    This will give you a list of all your CD-DVD ROMs Writers etc

    Then select your writer from the list and using the numerical target spec against that entry call "cdrecord -v -prcap dev=x,x,x"
    where x,x,x will be say 0,6,0 for a SCSI writer perhaps
    "ATAPI:0,1,0" perhaps for an ATAPI drive found using dev=ATAPI
    "ATA:0,1,0" perhaps for an ATAPI drive using dev=ATA
    (If you get both an ATAPI and a ATA listing, try the ATA first)

    That will get you the capabilities of your drive

    If it tells you what you already know (its a writer) thats fine. If it doesn't you have system specific problems I cant help with.

    A command "cdrecord -v dev=x,x,x -tao -dummy /some/filename.iso" will do a dummy burn to a CD disc on your writer.
    If all else fails actually read the man pages for cdrecord!!
    Depending on the version it may require to specify the mode "-tao" or similar, later versions assume it if nothing else given.

    If that works OK, junk K3b and get a decent program

    CDRchive on the www.freshmeat.net projects is good

    regards

    Melee

  3. #3
    Linux Enthusiast scientica's Avatar
    Join Date
    Sep 2003
    Location
    South- or "Mid-" Sweden
    Posts
    742
    just a little suggestion, you culd try X-CD-Roast, that's what I'm using (it emerged faster than k3b, I'll be testing k3b later on). Though X-CD-Roast is a little different at first look it worked fine when I burned a few backup discs (I had compiled ISOs with the data).

    btw, you haven't mounted the CD before startng k3b? (when I mount burned CDs it says it's write protected and mounts it read only).

    btw, which distro are you using?
    Regards Scienitca (registered user #335819 - http://counter.li.org )
    --
    A master is nothing more than a student who knows something of which he can teach to other students.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    Leper Khan,

    whatīs your distro and perhaps more importantly, whatīs your kernel?

    type uname -r for your kernel.

    If itīs 2.6.8 then itīs a known bug. I had the same error as you when I upgraded my kernel from 2.4. Had to compile 2.6.7 and now everything is working fine.
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  6. #5
    Linux User benjamin20's Avatar
    Join Date
    Oct 2004
    Location
    jacksonville beach FL
    Posts
    317
    from other posts his distro should be fc2
    nVidia G-Force 6600GT (bfg) pci-e: amd 64 2000+ (939): 1024 corsair ram: 2X 80gb seagate harddisk SATA: plextor cd/dvd-read/write cdrom SATA

  7. #6
    Just Joined!
    Join Date
    Sep 2004
    Location
    Manchester
    Posts
    50
    have you checked what your fstab says, when I installed FC2, it set my writer as a read only device, changed to read/write k3b worked fine, in fact I wrote my slackware cd's with it !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •