Find the answer to your Linux question:
Results 1 to 6 of 6
I have a LaCie NAS with 2 500 Gig drives in RAID 1. It is my back-up disk and archive. The NAS controller has evidently got a problem and is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2009
    Posts
    3

    Question Need HELP - Lacie 2Big NAS Recovery


    I have a LaCie NAS with 2 500 Gig drives in RAID 1. It is my back-up disk and archive. The NAS controller has evidently got a problem and is confused. It reported a drive bad so I sent the drive back to LaCie. They erased it, tested it, and sent it back as being OK. Now I only have 1 copy.

    I have corresponded with their help desk and basically they won't help access the data other than to tell me it is a Linux Op System. I do not understand their attitude. The last comment they made was that if they told me how to access my data it would void the warranty.

    I am windows centric but old DOS/VMS hand so I don't mind delving into Linux. Several posts here and elsewhere have led me to the following:

    1) I have latest knoppix on bootable CD
    2) I have accessed drive and have attached latest troubleshooting info as txt file.
    3) It appears to be be typical Linux RAID as mdadm reports info
    4) I am stymied by this error message:
    /dev/.tmp.md4. does not exist and is not a 'standard' name so it cannot be created
    5) At this point results have varied too far from posted info I have found.
    6) It looks to me like I should be able to rename RAID device but can't quite piece together how to do that.

    Can anyone help? I wish to mount drive and copy data to another location before I fool further with NAS.

    Regards,
    Bill
    Attached Files Attached Files

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,175
    Have you reinstalled the disc returned from Lacie? In any case, the error you are getting is that the drive is configured as part of a RAID array and it needs the second drive to work. If you reinstall it, it should re-mirror the data on the first drive. You should be able to access your data then. If not, then try the knoppix boot and see if it will let you mount the array - not the raw drive.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Sep 2009
    Posts
    3

    Question

    The controller in the LaCie NAS is damaged. The original problem stemmed from that.

    If you look at the bottom of the attached file I did try to mount the drive but there is a name problem.

    If I understand the Linux RAID system, it is able to mount an array even if the 2nd drive is unavailable. However I am stuck because I get the error message based on the naming issue.

    I need to find out how to get around that.

    Bill+

  4. #4
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,746
    Did you just try and mount the partition?
    Code:
    mount /dev/sdc2 /some/folder
    If so, what error do you get?

    Recover Data From RAID1 LVM Partitions With Knoppix Linux LiveCD
    - Ignore the LVM part. Once the md device is up, you're done.
    Last edited by HROAdmin26; 09-05-2009 at 03:28 AM.

  5. #5
    Just Joined!
    Join Date
    Sep 2009
    Posts
    3

    Question

    Look in attachment. All of the commands I tried are at the bottom with the resulting error messages.

  6. #6
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,746
    Quote Originally Posted by wdlindberg View Post
    Look in attachment. All of the commands I tried are at the bottom with the resulting error messages.
    Yes, I had...and there's no command where the partition is attempted to be mounted.

    A) Try mounting the partition and if that fails B) follow the steps to bring the md device online.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •