Hi,

I'm building a distro with the board PCM-9375, but my sound card don't work.

In the path /proc/asound I have:
card0 cards devices Audio modules oss pcm seq timers version
When I type cat cards it show:
# ls -l Audio:
Audio -> card0
# cat cards:
0[Audio ] cs5535audio - cs5535 Audio
CS5535 Audio cs5535audio at 0xfe00, irq 15
# cat devices:
2: : timer
3: : sequencer
4: [ 0- 0] : digital audio playback
5: [ 0- 0] : digital audio capture
6: [ 0 ] : control
# cat modules:
0 snd_cs5535audio
# cat pcm:
00-00 CS5535 Audio : CS5535 Audio : playback 1 : capture 1
# cat timers:
P0-0-0: PCM playback 0-0-0 : SLAVE
P0-0-1: PCM capture 0-0-1 : SLAVE
# cat version:
Advanced Linux Sound Architecture Driver Version 1.0.18a.


And the path /proc/asound/card0:
codec97#0
id
oss_mixer
pcm0c
pcm0p

These files seems nice but i cant hear sound.

When a type: cat /dev/urandom > /dev/audio
Nothing happens...

I load these modules:

# insmod soundcore.ko
# insmod sound_firmware.ko
# insmod snd.ko
# insmod snd-seq-device.ko
# insmod snd-rawmidi.ko
# insmod snd-mpu401-uart.ko
# insmod snd-page-alloc.ko
# insmod ac97_bus.ko
# insmod snd-timer.ko
# insmod snd-pcm.ko
# insmod snd-ac97-codec.ko
# insmod snd-mixer-oss.ko
# insmod snd-pcm-oss.ko
# insmod cs5535audio/snd-cs5535audio.ko
# insmod seq/snd-seq.ko
# insmod snd-seq-dummy.ko
# insmod snd-seq-midi.ko
# insmod snd-seq-midi-event.ko
# insmod snd-seq-midi-emul.ko
# insmod snd-seq-oss.ko

When I type:

# cat /dev/sndstat:
Sound Driver:3.8.1a-980706 (ALSA v1.0.18a emulation code)
Kernel: Linux xxxxxx i586
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
CS5535 Audio cs5535audio at 0xfe00, irq 15

Audio devices:
0: CS5535 Audio (DUPLEX)

Synth devices: NOT ENABLED IN CONFIG

Midi devices: NOT ENABLED IN CONFIG

Timers:
31: system timer

Mixers:
0: Realtek ALC203 rev 0
---------------------------------------------------

I have to do something in the kernel? I am forgetting something ? I m new in the compile kernel, i dont know if have more things to enable sound..


thanks.
fmnovais.