Find the answer to your Linux question:
Results 1 to 3 of 3
Sometimes I'll be able to use the scanner for a long time, do multiple scans, but sometimes it will hang while attempting to scan, and then these programs won't be ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    214

    Quiteinsane and kooka fail to find the scanner


    Sometimes I'll be able to use the scanner for a long time, do multiple scans, but sometimes it will hang while attempting to scan, and then these programs won't be able to find it. Sane-find-scanner still finds it though.

    I'll try with xsane, perhaps it's "closer" to sane-find-scanner, so likewise able to find it.

    I don't remember anymore, but I guess that if I reboot the scanner will work again, immediately after. But I guess sometimes it does not work even "for the first time".

    I've tried the simplest thing which is just to unplug and plug again (it's USB, by the way, canoscan lide 25), but it does not make it work again, at least not consistently. I think it happened once, when I repluged it in another port, but I've tried it other times with no success, I guess.

    Any idea?

  2. #2
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    214
    I apologize for bumping my own thread, but I'm still with the same problem, and clueless. Almost any suggestion above the absolute novice could be helpful.

    For example, could it have something to do with the kernel? How do I figure this? The fact that, sometimes it works, rules it out already, or could be that it an improper kernel compilation (default from Debian's repositories) made the scanner work, but only unreliably?

    If the kernel is not the main suspect, or can be ruled out, what else? USB-related "things", maybe? One thing I've read when searching for this sort of thing is that there's some USB-related issues with scanners, but I think that the particular issue I've read about isn't the case. I've briefly read about the USB being put to sleep due to inactivity and SANE having trouble to reactivate it. I think it shouldn't be the case because it won't work (most of the times) even immediately after I start the computer.

    Maybe the driver itself, perhaps the newer drivers (since it wasn't common sometime ago, if I'm recall) have some bug with this model specifically? (canoscan lide25)

    I can't think of anything else, not from the top of my head at least. I think that downgrading the driver is the easyest thing I can do without further advice, I'll try that.



    Ah, it's working consistently on windows (in another computer), so I think I can rule out hardware malfunction, unless is some little thing that somenow only linux drivers depends on.


    If that worths mentioning, I'm using Debian Lenny, with perhaps with a few packages from Sid, I don't remember which ones, probably related with Gimp (gtk and this sort of thing). I don't recall the scanner starting to become unreliably only after the mixing, and I'm not even sure it is still mixed.


    Thanks in advance for some light on that.

  3. #3
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    214
    Ok, I think I know what happened. It's not confirmed, but I'm about 99% sure.

    Some time ago there was a problem with an experimental kernel function, USB_SUSPEND. Back then I had actually found about this issue and compiled a kernel accordingly. I've used it for so long I forgot about that, so it was probably when debian suggested some kernel update via "mark all updates" on synaptic that I lost it and didn't even cross my mind.

    I've just compiled a newer kernel, again, disabling such feature, and it just worked. I think it will keep working from now on.


    [edit]



    Nope. It worked only once after I run the new kernel, but now I'm in the same situation.

    I still have no idea about what's going on. I don't think it's that an older version of the driver was better, actually, I've read that one of the older versions could even damage the scanner. I tried to compile newer drivers, but it failed, I don't understand why.


    Does anyone have a lide 25 working in a reliable manner on debian lenny, at least?
    Last edited by the dsc; 12-07-2009 at 06:29 PM.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •