Find the answer to your Linux question:
Results 1 to 6 of 6
I had this issue on an instillation of Arch and Ubuntu. Here's the video I took of it when it did this in Ubuntu, but it's the exact same thing ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Chao06's Avatar
    Join Date
    Aug 2008
    Location
    College Station, Texas, United States
    Posts
    40

    X11 doesn't seem to like my harddrive


    I had this issue on an instillation of Arch and Ubuntu.

    Here's the video I took of it when it did this in Ubuntu, but it's the exact same thing in Arch. When I run "startx" my monitor freaks out:
    YouTube - What my computer's doing

    It was on the same harddrive (Toshiba MK6034GAX), on the same computer (Dell Inspiron 6000).
    I also have an install of Ubuntu on a different harddrive that on the same computer boots Gnome in Ubuntu (same version, 9.04) no problem, so the only variable that could be causing the problem is the harddrive.

    Here's the harddrive specs for the Toshiba HDD
    http://sdd.toshiba.com/techdocs/MK60...otes-RevA0.pdf
    And here's for my other HDD (Seagate ST960822A) just for reference
    http://www.seagate.com/support/disc/...us_5400_pm.pdf

    Both installs on the offending disk were installed after fresh reformats.

    Does anyone have any idea, hypothesis, experience, anything that might help?
    Thanks,
    David

  2. #2
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    Perhaps the disk is no good? You should try booting up a live cd or inserting the disk into another linux machine and run fsck command on the partitions.

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,516
    Really, X and the hard drive are totally unrelated. Are you sure you have the same video driver installed on the drive that works, vs. the one that doesn't? As coopstah13 said, it could be a bad disc as well. In any case, what video driver did you specify when you installed Ubuntu and/or Arch on the drive that didn't work?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  4. #4
    Just Joined! Chao06's Avatar
    Join Date
    Aug 2008
    Location
    College Station, Texas, United States
    Posts
    40
    Well, in Ubuntu specifying a video driver isn't really necessary... It's always just worked out of the box, especially on this computer. In Arch I hadn't configured anything in X yet, I just installed xorg, gdm and XFCE4 and ran startx. Then it did the same thing as Ubuntu did, and figured it couldn't be coincidence. I'll run an fsck, but I'm almost positive there's not bad sectors or anything.

    Last night I ran
    dd if=/dev/zero of=/dev/hda
    on the harddrive, just to be thorough. I'm going to try installing again once I get back from work, and I'll run fsck as well before I start.

    I'll keep you posted.

    Thanks,
    David

  5. #5
    Just Joined! Chao06's Avatar
    Join Date
    Aug 2008
    Location
    College Station, Texas, United States
    Posts
    40
    so I ran the dd over night, and today I reinstalled Arch over it. It did the same thing, so I tinkered w/ some settings, and eventually by changing the video driver to the intel generic, I was able to get X (no XFCE, no gdm) but the mouse and keyboard didn't work. That's as far as I got with it.

    I gave up on that and decided to put Ubuntu back on the computer, that way I could tinker with something I was more familiar with, and it lo-and-behold works! And I don't have a clue why x_x

    This whole thing has given me a massive headache...

  6. #6
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,516
    Well, you can try to copy the /etc/X11/xorg.conf from your working drive to the non-working one and see if that works.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •