Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 18 of 18
Yes, I do have a user name and password....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Oct 2009
    Posts
    9

    Yes, I do have a user name and password.

  2. #12
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,533
    Ok. Try this. Login and start a terminal (command line) window. Then execute the command "sudo fdisk -l", after you have plugged in the USB drive. Report back results here.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #13
    Just Joined!
    Join Date
    Oct 2009
    Posts
    9
    Disk /dev/sda: 250.0 GB, 250059350016 bytes
    255 heads, 63 sectors/track, 30401 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x399b399a

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 29646 238131463+ 83 Linux
    /dev/sda2 29647 30401 6064537+ 5 Extended
    /dev/sda5 29647 30401 6064506 82 Linux swap / Solaris

    Disk /dev/sdb: 400.0 GB, 400088457216 bytes
    255 heads, 63 sectors/track, 48641 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x8b155b1b

    Device Boot Start End Blocks Id System
    /dev/sdb1 1 48641 390708801 7 HPFS/NTFS

  4. #14
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,533
    Good. The NTFS device+partition you want to mount is /dev/sdb1. So, in brief, what you want to do is this:

    1. Create mount point. For example: sudo mkdir /mnt/ntfs-usb1
    2. Mount ntfs file system: sudo ntfs-3g /dev/sdb1 /mnt/ntfs-usb1

    Try this and see if you can access the drive. It may not let you write to it as a regular user. If so, there are ways to fix that, but first let's make sure you can mount and access the file system.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  5. #15
    Just Joined!
    Join Date
    Oct 2009
    Posts
    9
    Right, I did that. This is what it said:

    $LogFile indicates unclean shutdown (0, 1)
    Failed to mount '/dev/sdb1': Operation not supported
    Mount is denied because NTFS is marked to be in use. Choose one action:

    Choice 1: If you have Windows then disconnect the external devices by
    clicking on the 'Safely Remove Hardware' icon in the Windows
    taskbar then shutdown Windows cleanly.

    Choice 2: If you don't have Windows then you can use the 'force' option for
    your own responsibility. For example type on the command line:

    mount -t ntfs-3g /dev/sdb1 /mnt/ntfs-fujitsu -o force

    Or add the option to the relevant row in the /etc/fstab file:

    /dev/sdb1 /mnt/ntfs-fujitsu ntfs-3g force 0 0

    I don't know if I'm doing something wrong or not.

  6. #16
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,533
    My guess is that when attached to a Windows system, the system was hibernated or suspended so that the drive is marked as "busy". There are options in ntfs-3g that will correct that. Read the man page for details. From the command line, execute the command: man ntfs-3g
    In any case, the error message was quite complete and even told you how to force it to mount with the -o force option. You can try that.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  7. #17
    Just Joined!
    Join Date
    Oct 2009
    Posts
    9
    I tried using the commands in the error message but they say I can't do it unless I log in as root. And I have no idea what that stuff is when I typed in man ntfs-3g...

    Sorry, I'm a bit pathetic. D:

  8. #18
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,533
    Did you run them with sudo? I've had issues with mount not liking sudo in the past, but there is a fix. You would need to enable the setuid bit on ntfs-3g: sudo chmod +s `which ntfs-3g`
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •