Find the answer to your Linux question:
Results 1 to 2 of 2
Okay, for the past 3 days I've spent some serious time trying to get my Acer Aspire One 110 to recognize and connect with my USB 3G card... I've made ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2009
    Posts
    1

    3G USB aircard not recognized properly


    Okay, for the past 3 days I've spent some serious time trying to get my Acer Aspire One 110 to recognize and connect with my USB 3G card...

    I've made some progress, thanks to quite a few others out there posting. I'm going to attempt to be methodical and post hopefully useful info:

    PROBLEM: When plugging in my 3G EVDO USB card, it's not being recognized via KPPP, GNOME PPP or Mobile Partner. I've tried just about every port within the options of KPPP and always immediately comes up with an error (Please make sure you have setup your modem device properly and/or adjust the location of the modem device on the modem tab of the setup dialog).

    Op Sys: Linpus Lite
    3G Card: Sierra Wireless 598 (made by Qualcomm, as the micro-sd card slot in it)
    3G Provider: Sprint

    Steps taken to recognize card:
    1) Installed Sierra Wireless drivers
    2) Started to setup the "usb_modeswitch"

    The 3G card is now recognized in dmesg and if I do a modinfo for sierra it returns the drivers. However, if I try to use on any port it doesn't recognize a modem connected. I've tried the applications listed above to connect, and they all act as if therej's no device attached.

    Here's a snippet of dmesg that shows the Sierra Wireless being detected, but changes from being a USB Modem to storage. Can anyone glean something from it that may help? Let me know if more info is needed.

    usb 2-2: new full speed USB device using uhci_hcd and address 3
    usb 2-2: configuration #1 chosen from 1 choice
    usb-storage: device ignored
    usbcore: registered new interface driver usbserial
    drivers/usb/serial/usb-serial.c: USB Serial Driver core
    drivers/usb/serial/usb-serial.c: USB Serial support registered for Sierra USB modem (1 port)
    drivers/usb/serial/usb-serial.c: USB Serial support registered for Sierra USB modem (3 port)
    sierra: probe of 2-2:1.0 failed with error -5
    usbcore: registered new interface driver sierra
    drivers/usb/serial/sierra.c: USB Driver for Sierra Wireless USB modems: v.1.2.5b
    usb 2-2: USB disconnect, address 3
    usb 2-2: new full speed USB device using uhci_hcd and address 4
    usb 2-2: configuration #1 chosen from 1 choice
    scsi3 : SCSI emulation for USB Mass Storage devices
    usb-storage: device found at 4
    usb-storage: waiting for device to settle before scanning
    usb-storage: device scan complete
    scsi 3:0:0:0: Direct-Access Sierra Wireless Storage 2.31 PQ: 0 ANSI: 2
    sd 3:0:0:0: [sdb] Attached SCSI removable disk
    sd 3:0:0:0: Attached scsi generic sg1 type 0

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,380
    Don't know about Linpus Lite, but Ubuntu 9.04 has no problems with these devices. In fact, it recognized mine "out-of-the-box" and connected me right up to my Sprint account. It looks like your system is trying to see it as a storage device and not a serial USB modem. Maybe you selected the wrong option when installing the software?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •