Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I have some problems with the cpu temperature of my new Toshiba satellite pro A300 laptop. While using windows the temperature is always between 40 50 C in linux ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    6

    cpu temperature and trip points


    Hi,

    I have some problems with the cpu temperature of my new Toshiba satellite pro A300 laptop.
    While using windows the temperature is always between 40 50 C in linux (Slackware 13) the cpu gets hot faster (between 55 and 65) also with a small load.

    The fan starts automatically only when the temperature reach 70.
    Code:
     
     critical (S5):           114 C
      passive:                 114 C: tc1=2 tc2=5 tsp=300 devices=CPU0 CPU1 
      active[0]:               70 C: devices= FAN
    So I tried to change the trip_points manually:

    Code:
    echo 90:0:52:52:50 > /proc/acpi/thermal_zone/THRM/trip_points"
    but I got "echo: write error: Input/output error".Maybe because is not possible change them anymore???

    I also tried to manually start the Fan
    Code:
    echo 0 >  /proc/acpi/fan/FAN/state
    But nothing change the fan is always on.

    Could someone explain me why the cpu gets so hot and How can I do to change my settings????

    Thanks
    Davide

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,655
    What distribution+version of linux are you running? It sounds like the CPU is running flat out. Laptops throttle the CPU speed most of the time in order to keep them from running so hot, and to increase battery run time. Since the fan is apparently running all the time, I think the temperature sensors and fan triggers are working ok. You need to enable CPU speed control if you can, which is why we need your distribution+version in order to help you figure out how to do that.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Jan 2008
    Posts
    6
    I use a Slackware 13.0 and my cpu is a Intel(R) Core(TM)2 Duo CPU P8600 @ 2.40GHz

    Using the sys fs I found out that my cpu scaling governonr is "userspace" and I dont have other possible governor.

    Reading the values in /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_cur_freq and /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_max_freq I also noticed that the current frequency is always
    2400000 very near to the maximum 2400100, even if a close most of the apps running an lower the cpu load.


    I intalled cpufreq but I didn't had time to learn how to use it.

    Thanks
    Davide

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,655
    Sorry, but I'm not familiar with the peculiarities of Slackware. I run Ubuntu on my laptops, and it seems to deal with power and cpu frequency management pretty well, at least on our 3 Dell laptops (2 of mine, one I gave to my grandson).
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •