Find the answer to your Linux question:
Results 1 to 6 of 6
There are posts in the forums and lists regarding setting up a SnapScan device like my Acer 4300 USB under Linuxes. I read them all and the problme is that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2009
    Location
    in a house
    Posts
    31

    Question Which device to use for snapscan/sane scanning?


    There are posts in the forums and lists regarding setting up a SnapScan device like my Acer 4300 USB under Linuxes. I read them all and the problme is that they all recommend editing snapscan.conf and setting the device to |dev|usb|scanner0.

    I don't have /dev/usb to start with!

    Code:
    # sane-find-scanner
    
    found USB scanner (vendor=0x04a5 [Color], product=0x20b0 [ FlatbedScanner 22]) at libusb:002:006
    
    # lsusb
    Bus 002 Device 006: ID 04a5:20b0 Acer Peripherals Inc. (now BenQ Corp.) S2W 3300U/4300U
    
    # SANE_DEBUG_SNAPSCAN=128 scanimage -L
    
    [snapscan] snapscani_usb_open(libusb:002:006)
    [snapscan] snapscani_mutex_open: using IPC key 0x20b00206 for device libusb:002:006 (pid 0x20b0, bus 0x02, dev 0x06)
    [snapscan] add_usb_device: Checking if 0x04a5 is a supported USB vendor ID
    ...
    [snapscan] snapscani_check_device: Is vendor "Color" model "FlatbedScanner22" a supported scanner?
    [snapscan] snapscani_get_model_id(FlatbedScanner22, 1, 2)
    [snapscan] snapscani_get_model_id: looking up scanner for ID 0x04a5,0x20b0.
    [snapscan] snapscani_check_device: Autodetected driver: Acer4300 (42 bit)
    [snapscan] snapscani_usb_close(1)
    [snapscan] 1st read 3 write 1
    [snapscan] snapscani_usb_cmd(1,0xbfaa7556,6,0x0,0x0 (0))
    [snapscan] atomic_usb_cmd(1,0xbfaa7556,6,0x0,0x0 (0))
    [snapscan] usb_cmd(1,0xbfaa7556,6,0x0,0x0 (0))
    [snapscan] usb_cmd: cmdlen=6, datalen=0
    [snapscan] usb_write: writing:  0x00 0x00 0x00 0x00 0x00 0x00
    [snapscan] Written 6 bytes
    [snapscan] usb_read: reading:  0xfb 0x00 0x00 0x00 0x00 0x00 0x00 0x00
    [snapscan] Read 8 bytes
    [snapscan] 2nd read 4 write 2
    [snapscan] snapscani_init_device_structure()
    [snapscan] sane_snapscan_get_devices (0xbfaa878c, 0)
    device `snapscan:libusb:002:006' is a Acer FlatbedScanner22 flatbed scanner
    [snapscan] sane_snapscan_exit
    Every time I detect the scanner and try scanimage, they do something to the scanner or USB port and next time scanimage will not do anything, just freeze. I have to plug the scanner off and back in to the power outlet. Then it changes the device number.

  2. #2
    Just Joined!
    Join Date
    Nov 2009
    Location
    in a house
    Posts
    31
    Is snapscan project alive at all?

    Apparently, there are some components of snapscan in F12, but the writeup from snapscan@sourceforge does not match the distro (programs are either missing in F12 or have different names).

    Did anyone manage to use snapscan under recent Fedora at all? What was your /dev device name?

  3. #3
    Linux Enthusiast minthaka's Avatar
    Join Date
    May 2006
    Location
    Mol, Vojvodina
    Posts
    556
    Have you red all the instructions? According to the descriptions, your scanner should work fine. Is this the first time you're installing your scanner on Linux?
    SnapScan Backend for SANE

    You also need to create a device if it does not exist :
    mknod /dev/usbscanner c 180 48
    Last edited by minthaka; 11-27-2009 at 07:10 AM.
    If you need a CD/DVD catalogizer, give a try to my program:
    http://www.kde-apps.org/content/show...content=100682
    Linux Usert#430188

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Nov 2009
    Location
    in a house
    Posts
    31
    Creating /dev/usbscanner did not help. The device is dead.
    So initially sane-find-scanner can see it on certain usbX device as Flatbed 22, then scanimage -L can see it too, but when I run scanimage, it times out and scanner no longer visible by both scanimage -L and sane-find-scanner.

    Yes, this is the 1st time I tried scanning under Linux.
    I've d/l firmware, put a path to it into snapscan.conf, but it's not clear which device to put there, as /dev/usbscanner does not work and /dev/usb/usbX keeps changing X after every time scnner has to be reset.

  6. #5
    Linux Enthusiast
    Join Date
    Dec 2011
    Location
    Turtle Island West
    Posts
    518
    I see this thread is a couple years old, but I'm having the exact same problem.

    I have 2 computers running the same OS (Mandrake 10). On one the scanner works perfectly. I got it working about 3 or 4 years ago but I don't recall having many issues. I think I had to 'mknod c usbscanner 180 48' and install a couple packages.

    On the other computer, where I've just moved the scanner, lsusb shows it:

    Bus 001 Device 003: ID 04a5:1a2a Acer Peripherals Inc. (now BenQ Corp.) Prisa 620U

    /proc/bus/usb/devices shows it:

    T: Bus=01 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#= 3 Spd=12 MxCh= 0
    D: Ver= 1.00 Cls=ff(vend.) Sub=ff Prot=ff MxPS= 8 #Cfgs= 1
    P: Vendor=04a5 ProdID=1a2a Rev= 1.21
    S: Manufacturer=Color
    S: Product=FlatbedScanner 5
    C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=100mA
    I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
    E: Ad=81(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms
    E: Ad=02(O) Atr=02(Bulk) MxPS= 8 Ivl=0ms
    E: Ad=83(I) Atr=03(Int.) MxPS= 8 Ivl=16ms

    sane-find-scanner finds it:

    found USB scanner (vendor=0x04a5 [Color], product=0x1a2a [FlatbedScanner 5]) at libusb:001:003

    But scanimage -L will only show it the first time after I cycle the power on the scanner. A second time and it hangs for about a minute until it says it can't find it. Of course it won't scan anything either.

    I even got fresh libusb source, along with sane frontends and backends, compiled and installed.

    I've been working on this for 2 days now to no avail. Why would this happen? What is scanimage doing?

  7. #6
    Linux Enthusiast
    Join Date
    Dec 2011
    Location
    Turtle Island West
    Posts
    518

    I think I found the problem

    After a bunch more trouble-shooting, it has nothing to do with the software.

    It's a flaky 5 volt supply from the mother board. Sometimes it works, mostly it doesn't, and it's getting worse. Even sometimes my thumb drives don't work. Anything connected to the power supply directly works fine, but stuff using 5V from the main board is unreliable or doesn't work at all. It's an older unit that worked great until a few months ago when things started getting funny.

    Oh well. Thankfully it's a big server case that I can use as an end table. Fancy geek heaven. If I plug it in I even have retractable cup holder and room heater.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •